hi,

> You have perl modules installed, that have no corresponding installed
> FreeBSD port.

i do not use BSDPAN -- it's sloppy about its dependency mgmt.

as i do on every other os/platform, i use ONLY "native" cpan/cpanp.

i have dozens of cpan-installed perl-modules.  cpan/cpanp manage the
dependencies just fine.

the problem is in the case of 'help2man'.

the port-install of help2man *DOES* use the cpan-installed gettext
perl-module correctly,

 pkg_info | grep help2man
   help2man-1.36.4_1   Automatically generating simple manual pages from
 pkg_delete help2man-1.36.4_1
 portinstall help2man
   --->  Installing 'help2man-1.36.4_1' from a port (misc/help2man)
   --->  Building '/usr/ports/misc/help2man'
   ...
   ===>   help2man-1.36.4_1 depends on file: /usr/local/bin/perl5.8.8 - found
   ===>  Applying FreeBSD patches for help2man-1.36.4_1
   ===>   help2man-1.36.4_1 depends on file:
/usr/local/lib/perl5/site_perl/5.8.8/mach/Locale/gettext.pm - found
   ...

*BUT*, in subsequent port updates/upgrades, it looks for the
p5-Locale-gettext* module.

looking in source,

cd /usr/ports/misc/help2man
grep p5-Locale-gettext *
 Makefile:BUILD_DEPENDS=
${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
 Makefile:RUN_DEPENDS=
${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext

and verifying in my system,

 module_info Locale::gettext
  Name:        Locale::gettext
  Version:     1.05
  Directory:   /usr/local/lib/perl5/site_perl/5.8.8/mach
  File:        /usr/local/lib/perl5/site_perl/5.8.8/mach/Locale/gettext.pm
Core module: no

there's no legitimate reason why it should NOT be looking for the
*correctly installed* gettext dependency in site_perl path ...

but, the fact remains that it isn't.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to