I'm trying to get my Canon A620 camera to work with gphoto2 under FreeBSD.

dmesg is telling me that my camera is /dev/ugen0.

[osiris temp] gphoto2 --list-ports
Devices found:
Path                             Description
ptpip:                           PTP/IP Connection
usb:                             Universal Serial Bus

[osiris temp] gphoto2 --port /dev/ugen0 -P
*** Error ***
An error occurred in the io-library ('I/O problem'): Failed to open
'/dev/ugen0' (m).
*** Error (-7: 'I/O problem') ***

[osiris temp] gphoto2 -L

*** Error ***
An error occurred in the io-library ('Bad parameters'): Could not find USB
device (vendor 0x4a9, product 0x30fc). Make sure this device is connected to
the computer.
*** Error (-2: 'Bad parameters') ***

I tried using --debug, but it didn't seem to give me that much more detail,
at least that I could understand.  I also tried specifying the port as "usb"
and the camera as "Canon PowerShot A620 (PTP mode)" (as specified in gphoto2
--list-cameras).  None of this worked.  Each gave me the "bad parameters"
error, which is slightly frustrating.

I believe that this could be due to the fact that the camera is being seen
as ugen0 instead of usb.  Is there a way to cause it to be seen as usb?


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to