You should try to mount your camera manually first as
su -
mount_msdosfs /dev/ugen0 /mnt

If you can not read the camera only then you should use gphoto2 but logged as a supper user to avoid permission problems. If that fails i.e. if you get the message BLOCK DEVICE RECUIRED you
should try to use gphoto2.

This is step by step for my Sony Cyber-Shot W70
1. Change into PTP mode on camera
2. Go to su mode (this can be avoided but I left it so that my wife cannot mess with it) 3. gphoto2 --auto-detect will list your camera as Sony DSC-F707V (PTP mode) usb:
4. gphoto2 --help to get various commands
5 gphoto2 --L will list all the files in numerical order
6 gphoto2 --get-file=NUMBER Range (will get you files in that range)
7 WARNING you may need to issue the commands some time multiple times because
they fail. The following message is not uncommon
*** Error ***

Note you might not need to go to PTP mode for your particular camera!

If that fail then you can use cheap card reader which are well detected by FreeBSD.

There is an excellent thread that you can review

maybe somebody left specific details for you camera but I think I gave you a big push:-)

Please let me know how it goes.


Erin McNew wrote:
I'm trying to get my Canon A620 camera to work with gphoto2 under FreeBSD.

dmesg is telling me that my camera is /dev/ugen0.

[osiris temp] gphoto2 --list-ports
Devices found:
Path                             Description
ptpip:                           PTP/IP Connection
usb:                             Universal Serial Bus

[osiris temp] gphoto2 --port /dev/ugen0 -P
*** Error ***
An error occurred in the io-library ('I/O problem'): Failed to open
'/dev/ugen0' (m).
*** Error (-7: 'I/O problem') ***

[osiris temp] gphoto2 -L

*** Error ***
An error occurred in the io-library ('Bad parameters'): Could not find USB
device (vendor 0x4a9, product 0x30fc). Make sure this device is connected to
the computer.
*** Error (-2: 'Bad parameters') ***

I tried using --debug, but it didn't seem to give me that much more detail,
at least that I could understand.  I also tried specifying the port as "usb"
and the camera as "Canon PowerShot A620 (PTP mode)" (as specified in gphoto2
--list-cameras).  None of this worked.  Each gave me the "bad parameters"
error, which is slightly frustrating.

I believe that this could be due to the fact that the camera is being seen
as ugen0 instead of usb.  Is there a way to cause it to be seen as usb?


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to