Some cameras can be mounted without any software on FreeBSD. Yours is not one of those so be it.
No we are going to use gPhoto2.

If you play (ON THE MENU OF CAMERA) with the options on YOUR CAMERA in particular options for USB connector you will see that the following options likely will be displayed
Pict Bridge
Mass Storage

By default the camera is in Auto mode which is good enough for Windozzz but FreeBSD might want you to put camera in PTP mode usually used when camera is directly connected to PRINTER via
Then just follow the steps I gave you.
I am 99% sure that your camera DOES work with FreeBSD.


Erin McNew wrote:
Thank you for the suggestions. I did try mounting the camera, but since I had to use gphoto2 in linux, I figured I'd probably need to do so in freebsd as well. It gave me the message saying it required a block device.

I do not quite know what you mean about switching my camera to PTP mode. I did not need to do anything special under Linux, but I will google a bit to see what I can figure out related to that. I will look into your suggestions a bit more closely tonight when I get back home. If I'm understanding your explanation correctly, the fact that my camera is showing up as ugen0 instead of usb0 is not a problem, correct?


On 9/5/07, *Predrag Punosevac* <[EMAIL PROTECTED] <mailto:[EMAIL PROTECTED]>> wrote:

    You should try to mount your camera manually first as
    su -
    mount_msdosfs /dev/ugen0 /mnt

    If you can not read the camera only then you should use gphoto2 but
    logged as a supper user to avoid
    permission problems. If that fails i.e. if you get the message BLOCK
    should try to use gphoto2.

    This is step by step for my Sony Cyber-Shot W70
    1. Change into PTP mode on camera
    2. Go to su mode (this can be avoided but I left it so that my wife
    cannot mess with it)
    3. gphoto2 --auto-detect will list your camera as Sony DSC-F707V (PTP
    mode) usb:
    4. gphoto2 --help to get various commands
    5 gphoto2 --L will list all the files in numerical order
    6 gphoto2 --get-file=NUMBER Range (will get you files in that range)
    7 WARNING you may need to issue the commands some time multiple times
    they fail. The following message is not uncommon
    *** Error ***

    Note you might not need to go to PTP mode for your particular camera!

    If that fail then you can use cheap card reader which are well
    by FreeBSD.

    There is an excellent thread that you can review

    maybe somebody left specific details for you camera but I think I gave
    you a big push:-)

    Please let me know how it goes.


    Erin McNew wrote:
    > I'm trying to get my Canon A620 camera to work with gphoto2
    under FreeBSD.
    > dmesg is telling me that my camera is /dev/ugen0.
    > [osiris temp] gphoto2 --list-ports
    > Devices found:
    > 2
    > Path                             Description
    > --------------------------------------------------------------
    > ptpip:                           PTP/IP Connection
    > usb:                             Universal Serial Bus
    > [osiris temp] gphoto2 --port /dev/ugen0 -P
    > *** Error ***
    > An error occurred in the io-library ('I/O problem'): Failed to open
    > '/dev/ugen0' (m).
    > *** Error (-7: 'I/O problem') ***
    > [osiris temp] gphoto2 -L
    > 1
    > *** Error ***
    > An error occurred in the io-library ('Bad parameters'): Could
    not find USB
    > device (vendor 0x4a9, product 0x30fc). Make sure this device is
    connected to
    > the computer.
    > *** Error (-2: 'Bad parameters') ***
    > I tried using --debug, but it didn't seem to give me that much
    more detail,
    > at least that I could understand.  I also tried specifying the
    port as "usb"
    > and the camera as "Canon PowerShot A620 (PTP mode)" (as
    specified in gphoto2
    > --list-cameras).  None of this worked.  Each gave me the "bad
    > error, which is slightly frustrating.
    > I believe that this could be due to the fact that the camera is
    being seen
    > as ugen0 instead of usb.  Is there a way to cause it to be seen
    as usb?
    > Thanks!
    > ~Erin


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to