Hi there again,

2007/9/12, Ian Smith <[EMAIL PROTECTED]>:
> On Tue, 11 Sep 2007 19:19:32 +0200 Zbigniew Szalbot wrote:
>
>  > I decided to upgrade my home machine to php5.2.3 from 4.4.7. All went
>  > fine. I had one error about hash extension already loaded which I
>  > solved by deleting a duplicated entry from extensions.ini. The curious
>  > thing is that once apache has been restarted, if I want to load a
>  > website which resides on this box, it behaves as if no php was enabled
>  > in apache. In other words I can see the directory content (files
>  > present in a given directory) despite index.php being there. What is
>  > more strange is that when I click reload, the website is indeed loaded
>  > into browser! So when I first type an URL, it shows directory content.
>  > After hitting reload in browser (tested with both FF and IE), the page
>  > is shown.
>
> Except for the reload bit - perhaps I never tried that - I've been here.
>
>  > My first thought was checking httpd.conf
>  >
>  >         <IfModule mod_php5.c>
>  >             DirectoryIndex index.php index.php3 index.html
>  >         </IfModule>
>  >
>  > and also
>  >     AddType application/x-tar .tgz
>  >     AddType application/x-httpd-php .php
>  >     AddType application/x-httpd-php-source .phps
>
> The latter AddTypes should be within <IfModule mod_mime.c> section?

No, it wasn't in there but I moved it to this section. There is no
difference. I cannot start apache.

>
> index.php3 there looks a bit odd, unless you're supporting some old
> .php3 scripts? If you're then still having trouble, show us the whole
> <IfModule mod_dir.c> .. </IfModule> section?
>
> For a php4 to php5 update, make sure you also have such as:
>
> #LoadModule php4_module libexec/apache/libphp4.so
> LoadModule php5_module  libexec/apache/libphp5.so
>
> and
>
> #AddModule mod_php4.c
> AddModule mod_php5.c
>
> And check that /usr/local/libexec/apache/libphp5.so exists!

Everything is fine here. But I think now that the problem is not with
apache but with php. It does not even matter if I do start or
startssl. In both instances the httpd server dies. The reason I think
it is php-related is that when I issue php -v I get:

PHP 5.2.3 with Suhosin-Patch 0.9.6.2 (cli) (built: Sep 12 2007 08:59:52)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
Segmentation fault (core dumped)

pkg_info | grep php5
php5-5.2.3_1        PHP Scripting Language (Apache Module and CLI)

I do not really feel like upgrading apache (as suggested by someone
else - thank you by the way) because it is just a home machine on
which I do not need all the greatest and latest.

If there's nothing obvious that comes to your mind I will try posting
it on a php list.

Thank you!

Zbigniew Szalbot
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to