Crist J. Clark wrote:
On Thu, Sep 13, 2007 at 03:15:10PM -0700, Predrag Punosevac wrote:
I know where is your problem the burning device is always cd0

Huh? Burncd(8) is explicitly for ATAPI CD-R/RW. From the man page,

       The burncd utility is used to burn CD-R/RW media using the ATAPI cd

All of the examples on the manpage use /dev/acd0.

you must give the device node /dev/cd0

If I try it,

  # burncd -f /dev/cd0 -v -s 32 data hw.iso fixate
  burncd: ioctl(CDRIOCGETBLOCKSIZE): Device not configured

Crist J. Clark wrote:
On Thu, Sep 13, 2007 at 01:21:09PM -0700, Predrag Punosevac wrote:
Make sure you add atapicam into your kernel it is not in generic! I had the same problem.

/etc/loader.conf   atapicam_load="YES"
I did a,

        # kldload /boot/kernel/atapicam.ko

And to reinitiallize the drive,

        # atacontrol detach ata1
        # atacontrol attach ata1

I got the same console message,

 acd0: detached
 (cd0:ata1:0:0:0): lost device
 (cd0:ata1:0:0:0): removing device entry
 atapicam1: detached
 stray irq15
 acd0: CDROM <CRD-8400B/1.06> at ata1-master UDMA33

And still get,

        # burncd -f /dev/acd0 -t -s 32 data ~cjc/hw.iso fixate
        burncd: ioctl(CDIOCSTART): Input/output error

Crist J. Clark wrote:
I just tried to burn a CD for the first time in a long time
on a machine. The burncd(8) command worked fine on this machine
in FreeBSD 5.x (or was it 4.x?), but now in 6.2, I get,

# burncd -f /dev/acd0 -s 32 data hw.iso fixate
burncd: ioctl(CDIOCSTART): Input/output error

Looking at the dmesg(1) from the last boot,

# fgrep cd0 /var/run/dmesg.boot
acd0: CDROM <CRD-8400B/1.06> at ata1-master UDMA33

Makes me think the system is not recognizing the device as CDRW,
only CDROM. I get this from atacontrol(8),

# atacontrol info ata1
Master: acd0 <CRD-8400B/1.06> ATA/ATAPI revision 0
Slave:       no device present
# atacontrol cap acd0

Protocol              ATA/ATAPI revision 0
device model          CRD-8400B
serial number         1999/10/12
firmware revision     1.06
cylinders             0
heads                 0
sectors/track         0
lba supported lba48 not supported dma supported
overlap not supported

Feature                      Support  Enable    Value           Vendor
write cache                    no       no
read ahead                     no       no
Tagged Command Queuing (TCQ)   no       no      0/0x00
SMART                          no       no
microcode download             no       no
security                       no       no
power management               no       no
advanced power management      no       no      0/0x00
automatic acoustic management  no       no      0/0x00  0/0x00

How can I restore burning capability?

I can just repeat what I read in the Gnome FreeBSD book that enable me to burn CD and DVD.


device          scbus
device          cd
device          pass
This IS in GENERIC kernel or it was in 6.2 Stable.
You must also make sure you have the following configured in your kernel if you are using an ATAPI CD/DVD drive:

device     atapicam
THIS IS NOT IN THE GENERIC KERNEL! I added atapicam_load="YES" into my /boot/loader.conf file and
rebooted my computer as it is not a server.

To figure out which CD/DVD drive you will be using, run the following command as root:

# camcontrol devlist
Your output will look similar to the following:

<QSI CDRW/DVD SBW-242 UD22>      at scbus1 target 0 lun 0 (cd0,pass0)
The devices in parentheses at the end are important. You must make sure the /dev entries for those devices are writable by the users that will be using nautilus-cd-burner, totem, goobox, or sound-juicer. In addition to those devices, /dev/xpt* must also be writable to your nautilus-cd-burner, totem, goobox, and sound-juicer users. The following /etc/devfs.conf configuration will achieve the desired results given the above devlist:

perm    cd0     0666
perm    xpt0    0666
perm    pass0   0666
I also have
link acd0 cd0
perm acd0 0666
perm cd0  0666

I did burn on Sunday iso DVD from the command line! The device node was /dev/cd0
since somebody told me that it has to be cd0 not acd0. (Maybe it is true only 
for DVD
and if I remember examples from the book about DVD burning it was cd0)
I was supper user during the burning to avoid any possibility of permission 
I did burn at least 4 CD with music and one data CD using K3b since my Nautilus (I have Gnome on this system) is complaining about something. I was logged into my regular account when I used K3b. Obviously not supper user mode. I like K3B better than any of the Gnome applications anyway so I am not going to bother about Nautilus.

I read the Handbook carefully and also FAQ. I am sure I forgot quite a bit as my system is fully configured and I am mostly light user (text editing, mail, browsing, FTP,
VNC, and occasional multimedia)


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to