Hi,

(I originally posted this on the freebsd-gnome mailing list and then realized that list was for people actively working on Gnome. I don't know if my question is a Gnome-specific issue or if it is an issue that can arise when installing programs in general.)


I am currently using FreeBSD 6.2 RELEASE and I am trying to install gnome2-office via the ports collection. After running 'portsnap fetch update' I 'make install clean' in the gnome2-office directory. It goes well until:

   *
   *
   *
gmake[2]: Entering directory
`/usr/ports/databases/libgda3/work/libgda-1.9.102/doc/C'
gmake[2]: Nothing to be done for `all'.
gmake[2]: Leaving directory
`/usr/ports/databases/libgda3/work/libgda-1.9.102/doc/C'
gmake[2]: Entering directory
`/usr/ports/databases/libgda3/work/libgda-1.9.102/doc'
gmake[2]: Nothing to be done for `all-am'.
gmake[2]: Leaving directory
`/usr/ports/databases/libgda3/work/libgda-1.9.102/doc'
gmake[1]: Leaving directory
`/usr/ports/databases/libgda3/work/libgda-1.9.102/doc'
gmake[1]: Entering directory
`/usr/ports/databases/libgda3/work/libgda-1.9.102'
gmake[1]: Nothing to be done for `all-am'.
gmake[1]: Leaving directory
`/usr/ports/databases/libgda3/work/libgda-1.9.102'
===>  Installing for libgda3-1.9.102_3
===>  libgda3-1.9.102_3 conflicts with installed package(s):
     libgda2-1.2.4_1,1
     They install files into the same place.
     Please remove them first with pkg_delete(1).
*** Error code 1
Stop in /usr/ports/databases/libgda3.
*** Error code 1
Stop in /usr/ports/math/gnumeric.
*** Error code 1
Stop in /usr/ports/math/gnumeric.
*** Error code 1
Stop in /usr/ports/editors/gnome2-office.
***


  ...so I:


root# pkg_delete libgda2-1.2.4_1,1
pkg_delete: package 'libgda2-1.2.4_1,1' is required by these other packages
and may not be deinstalled:
py25-gnome-extras-2.14.3_3
straw-0.27
gnome2-fifth-toe-2.18.3
***


   ...so I then try to install the new libgda separately:

root# make install clean
===>  Installing for libgda3-1.9.102_3
===>  libgda3-1.9.102_3 conflicts with installed package(s):
     libgda2-1.2.4_1,1
     They install files into the same place.
     Please remove them first with pkg_delete(1).
*** Error code 1

I am new to the subtle inner workings of FreeBSD.  Could anyone please
advise, suggest, or comment on how I should proceed?  It seems that
I can't install the new libgda unless I delete the old one, but I am
prevented from deleting the old one because at least three other programs
are dependent upon it.

(As an aside, is it okay to run these installations from a terminal window
from inside the Gnome GUI environment, or should I be outside of Gnome
altogether when I do program installations/upgrades?)

Thanks,
Larry


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to