On 9/20/07, Doug Poland <[EMAIL PROTECTED]> wrote:
> Hello,
> I've been following the various instructions I've found on the web in an
> attempt to get tap networking with qemu-devel-0.9.0s.20070802 and
> kqemu-kmod-1.3.0.p11_2 on 6.2-STABLE.
> qemu was compiled with:
>    _OPTIONS_READ=qemu-devel-0.9.0s.20070802
>    WITH_KQEMU=true
>    WITHOUT_RTL8139_TIMER=true
>    WITH_SDL=true
>    WITH_CDROM_DMA=true
> The kernel modules are loaded:
>    if_tap, bridge, aio, kqemu
> The sysctls are changed:
>    sysctl net.link.ether.bridge_cfg=ath0,tap0
>    sysctl net.link.ether.bridge.enable=1
> The tap device exists:
>    crw-------  1 root  wheel    0, 134 Sep 19 22:42 /dev/tap0
>    tap0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>         inet netmask 0xff000000 broadcast
>         ether 00:bd:01:3c:01:00
>         Opened by PID 1317
> The qemu-ifup script exists:
>    cat /etc/qemu-ifup
>      #!/bin/sh
>      ifconfig ${1}
> I launch qemu like this:
>    qemu -m 512 -localtime -hda VMs/w2k3.img -net nic -net tap
> Windows Server 2003 comes up.  If I attempt to use DHCP to configure the
> interface in W2K3, I get a several minute pause while it attempts to
> contact a DHCP server, finally it fails with the message:
>    "This connection has limited or no connectivity"
> and windows assigns itself the address.
> If I try to manually configure the windows interface, i.e.,
>    IP:
>    NM:
>    DG:
>    NS:
>    NS:
> Windows thinks it has connectivity, but I cannot ping the default
> gateway from the guest and I cannot ping the IP of the guest from the
> host.
> So at this point, I have no networking from the guest OS.  About the
> only thing that I haven't seen on the web is people using wireless NICs
> in the host.  In my case, I have an atheros chipset connected via WPA2
> to my WAP.
> All help is appreciated...

I just got tap working with an earlier build of qemu using clues from this site:


Also, I can only get it working when I run it with sudo at the moment
and I have only tried with a wired nic.  I have read in some places
that encryption causes problems with tap, but I don't have a link to
where I read it.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to