On September 21, 2007 at 09:53AM Aliya Harbouri wrote:

> Hi!
> 
> When I ran an upgrade to the Ports tree using the "portsnap" tool
> 
>   portsnap fetch update
> 
> I saw an available update available to /usr/ports/www/apache22, but it
> was immediately followed with an error,
> 
>   IGNORED
>   Unknown Berkeley DB version
> 
> in the console output.
> 
> Other ports eventually get updated, but apache22 seems to get skipped
> as a result.
> 
> It took me a bit to figure out that the "IGNORE" is coming from the
> Port's "Makefile.modules",
> 
>       IGNORE=     "Unknown Berkeley DB version"
> 
> I've read online about use of "/usr/ports/Mk/bsd.database.mk" &
> "/etc/make.conf" for build configuration, and have added
> 
>  USE_BDB
>  WITH_BDB_HIGHEST=true
>  WITH_BDB_VER=46
>  BDB_LIB_DIR=/usr/local/lib/db46
>  BDB_INCLUDE_DIR=/usr/local/include/db46
> 
> to make.conf.  If I grok this stuff correctly, Ports should now find &
> use BDB, version 46.
> 
> Good news! This seems to make all other Ports generally happy.  They
> seem to find/use BDB like I intend.
> 
> But the apache22 Port still doesn't update, because of the "Unknown"
> BDB version.
> 
> Is there some additional Ports-magic that I'm missing here?
> 
> Ali

I have been having the same problem with the latest version of
Berkeley. I was going to contact the maintainer '[EMAIL PROTECTED]';
however, I have not gotten around to it yet. Perhaps you might want to
inquire of him how to get this problem rectified.


-- 
Ciao

Gerard
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to