On Sun, 30 Sep 2007 13:52:58 -0600 bob <[EMAIL PROTECTED]> wrote:
 > My business has been using PHP for years.  Mysql outputs to my browser, 
 > where I can print invoices, bills and any business statitic.
 > Suddenly, my browser started acting funny.  I don't know how to use the 
 > repair disk to fix a problem, so I reinstalled FreeBSD-6.1.  It still 
 > works the same except I can't get phpinfo() to display in the browser.  
 > I can do php -i, which displays several pages of PHP code.  That means 
 > PHP is working.  I don't use CGI or PHP scripts.  If phpinfo() doesn't 
 > show up in my browser, I can't do anything.
 > The following is in /usr/local/etc/apache/httpd.conf:
 >  LoadModule php5_module

LoadModule php5_module        libexec/apache/libphp5.so

 >  AddModule mod_php5.c
 >  DirectoryIndex index.php index.html
 >  DirectoryIndex index.html

Last match wins: remove latter DirectoryIndex to have index.php work.

 >  AddType application/x-httpd-php .php
 >  AddType application/x-httpd-php-source .phps
 > The httpd.error.log doesn't show any problems.  Thre are 35 modules in 
 > /usr/local/libexec/apache including libphp5.so and httpd.exp.  Php.ini 
 > is installed at /usr/local/lib

php.ini (from the default php5 port) installs in /usr/local/etc:

paqi% ll -rt /usr/local/etc/|grep php
-r--r--r--  1 root   wheel   39243 May  5  2006 php.ini.php4.05May06
drwxr-xr-x  2 root   wheel     512 Dec 17  2006 php
-rw-r--r--  1 root   wheel   27669 Dec 17  2006 diff_php.ini.4vs5rec
-r--r--r--  1 root   wheel   46221 Dec 18  2006 php.ini-recommended
-r--r--r--  1 root   wheel   42919 Dec 18  2006 php.ini-dist
-r--r--r--  1 root   wheel      49 Dec 18  2006 php.conf
-r--r--r--  1 root   wheel   43278 Dec 19  2006 php.ini

 > This time I installed mysql-5.1, apache-1.3 and PHP-5.1.  I used 
 > "pkg_add -r" to install apache and mysql.  Apache and mysql work 
 > excellent.  I installed PHP from www.php.net. Both PHP4 and PHP5 would 
 > fail to load the phpinfo() file. I installed PHP-5.1 from the ports 
 > directory.  Same problem.   I ordered FreeBSD-6.1, before it was 
 > available.  The FreeBSD Mall had it, but wasn't promoting it yet.
 > About 2 years ago when I first installed FreeBSD-6.1, I installed 
 > mysql-4.0, PHP-4 and apache-1.3 on FreeBSD-6.1.  I used "pkg_add -r" to 
 > install apache and mysql and I downloaded PHP-4 from www.php.net.  
 > Everything worked, including PHP.  Two years ago, www.php.net was 
 > supplying any version of PHP including older versions of PHP-4.  I 
 > installed  older versions because they worked.
 > Now www.php.net only supplies the latest version.

The php5 port applies heaps of patches to the php.net sources; I think
you'll save yourself lots of grief by using the port.

I suggest (saving configs and) uninstalling php, then install it from
lang/php5.  Assuming your ports tree is up to date - and it had probably
better be regarding dependencies - then install php5 (5.2.something).

Make sure to set the apache module on (it's turned off by default, for
some bizarre reason, so pkg_add -r php5* is broken), by running make
config first, though the options screen should come up on the initial
install anyway.  You may want to install lang/php5-extensions too .. 

Cheers, Ian

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to