At 04:31 PM 10/10/2007, White Hat wrote:
This is driving me crazy. I have a small script that I
run from CRON. It is run as a regular user and not as
ROOT, although I have tried it both ways. It uploads
SPAM to the '' site'.

I have created a ~/.netrc file that looks like this:

        login user
        password secret

macdef  spam
        put $1

Now, if I run the following command from the command
prompt, the script works fine.

echo \$ spam | ftp -n
ftp://user:[EMAIL PROTECTED]

The above should all be on one line, although it may
be shown split into two right now.

However, if this is put into a bash script, and run if
from CRON, I receive a mail with this error message:

'spam' macro not found.

I have no idea what I am doing wrong.

I have the $HOME, $SHELL and $PATH variables set in

try set -x and see what the output looks like. I'd guess you are not escaping the $ right in your script.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
MailScanner thanks transtec Computers for their support.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to