I have  a FreeBSD-6.2 server box , I am trying to settup my mailinlists
system in this box , I have postfix installation working file , in
order to create mailing lists ,



Here I tried to install Mailman from /usr/ports to be used with postfix
MTA  but I got an error , pls help me to fix thsi error 





[EMAIL PROTECTED] /usr/ports/mail/mailman]# pwd

/usr/ports/mail/mailman

[EMAIL PROTECTED] /usr/ports/mail/mailman]# make all install clean 
MM_GROUPNAME=nobody MM_GROUPID=65534

cd /usr/ports/mail/mailman && make config;

..............



===>  Vulnerability check disabled, database not found

===>  Found saved configuration for mailman-2.1.9_4



You may change the following build options:

MM_USERNAME=mailman     The username of the Mailman user.

MM_USERID=91            The user ID of the Mailman user.

MM_GROUPNAME=mailman    The group to which the Mailman user will belong.

MM_GROUPID=MM_USERID    The group ID for the Mailman user.

MM_DIR=mailman          Mailman will be installed in /usr/local/mailman.

CGI_GID=www            
The group name or id under which your web server executes CGI scripts.

IMGDIR=www/icons        Icon images will be installed in /usr/local/www/icons.



=> mailman-2.1.9.tgz doesn't seem to exist in /usr/ports/distfiles/mailman.

=> Attempting to fetch from 
http://heanet.dl.sourceforge.net/sourceforge/mailman/.

mailman-2.1.9.tgz                            
100% of 7645 kB   36 kBps 00m00s

===>  Extracting for mailman-2.1.9_4

=> MD5 Checksum OK for mailman/mailman-2.1.9.tgz.

=> SHA256 Checksum OK for mailman/mailman-2.1.9.tgz.

===>  Patching for mailman-2.1.9_4

===>  Applying FreeBSD patches for mailman-2.1.9_4

===>   mailman-2.1.9_4 depends on file: /usr/local/bin/python2.5 - found

===>  Configuring for mailman-2.1.9_4

---> Starting install script:

---> Using existing group "nobody"

---> Adding user "mailman" (91)

---> Creating Mailman directory (/usr/local/mailman)

creating cache ./config.cache

checking for --with-python... /usr/local/bin/python2.5

checking Python interpreter... /usr/local/bin/python2.5

checking Python version... 2.5.1

checking that Python has a working distutils... yes

checking for a BSD compatible install... /usr/bin/install -c -o root -g wheel

checking whether make sets ${MAKE}... yes

checking for true... /usr/bin/true

checking for --without-gcc... no

checking for gcc... cc

checking whether the C compiler (cc -O2 -fno-strict-aliasing -pipe  ) works... 
yes

checking whether the C compiler (cc -O2 -fno-strict-aliasing -pipe  ) is a 
cross-compiler... no

checking whether we are using GNU C... yes

checking whether cc accepts -g... yes

checking whether #! works in shell scripts... yes

checking for --with-var-prefix... no

checking for --with-permcheck... yes

checking for --with-username... mailman

checking for user name "mailman"... okay

checking for --with-groupname... nobody

checking for group name "nobody"... okay

checking permissions on /usr/local/mailman... okay

checking for mail wrapper group; i.e. --with-mail-gid... configure: error:

***** No group name "mailman" found for the mail wrapper program.

***** This is the group that your mail server will use to run Mailman's

***** programs.  You should specify an existing group with the

***** --with-mail-gid configure option, or use --without-permcheck to

***** skip this verification step.  See also your mail server's documentation,

***** and Mailman's INSTALL file for details

===>  Script "configure" failed unexpectedly.

Please report the problem to [EMAIL PROTECTED] [maintainer] and attach the

"/usr/ports/mail/mailman/work/mailman-2.1.9/config.log" including the output

of the failure of your make command. Also, it might be a good idea to provide

an overview of all packages installed on your system (e.g. an `ls

/var/db/pkg`).

*** Error code 1



Stop in /usr/ports/mail/mailman.

*** Error code 1



Stop in /usr/ports/mail/mailman.

[EMAIL PROTECTED] /usr/ports/mail/mailman]#



Please help me to install mailman successfully 





Thanks in Advance 

kk_CHN











here the  mailman config.log 





[EMAIL PROTECTED] ~]# tail -200 
/usr/ports/mail/mailman/work/mailman-2.1.9/config.log

This file contains any messages produced by compilers while

running configure, to aid debugging if configure makes a mistake.



configure:558: checking for --with-python

configure:612: checking Python interpreter

configure:628: checking Python version

configure:662: checking that Python has a working distutils

configure:728: checking for a BSD compatible install

configure:781: checking whether make sets ${MAKE}

configure:810: checking for true

configure:846: checking for --without-gcc

configure:875: checking for gcc

configure:988: checking whether the C compiler (cc -O2 -fno-strict-aliasing 
-pipe  ) works

configure:1004: cc -o conftest -O2 -fno-strict-aliasing -pipe    conftest.c  
1>&5

configure:1030: checking whether the C compiler (cc -O2 -fno-strict-aliasing 
-pipe  ) is a cross-compiler

configure:1035: checking whether we are using GNU C

configure:1044: cc -E conftest.c

configure:1063: checking whether cc accepts -g

configure:1115: checking whether #! works in shell scripts

configure:1148: checking for --with-var-prefix

configure:1163: checking for --with-permcheck

configure:1195: checking for --with-username

configure:1213: checking for user name "mailman"

configure:1259: checking for --with-groupname

configure:1278: checking for group name "nobody"

configure:1323: checking permissions on /usr/local/mailman

configure:1379: checking for mail wrapper group; i.e. --with-mail-gid

[EMAIL PROTECTED] ~]#





Here is the  /var/db/pkg 



apache-2.2.6                   
libXvMC-1.0.4                  
php5-bcmath-5.2.4

arc-5.21o_1                    
libXxf86dga-1.0.2              
php5-ctype-5.2.4

arj-3.10.22                    
libXxf86misc-1.0.1             
php5-dom-5.2.4

atk-1.18.0_1                   
libXxf86vm-1.0.1               
php5-extensions-1.1

autoconf-2.59_3                
libassuan-1.0.3                
php5-gettext-5.2.4

autoconf-wrapper-20070404      
libdmx-1.0.2                   
php5-iconv-5.2.4

bash-3.2.25                    
libdrm-2.3.0                   
php5-imap-5.2.4

bdftopcf-1.0.1                 
libfontenc-1.0.4               
php5-mcrypt-5.2.4

bigreqsproto-1.0.2             
libfpx-1.2.0.12                
php5-mysql-5.2.4

bitstream-vera-1.10_4          
libgcrypt-1.2.4_1              
php5-mysqli-5.2.4

cairo-1.4.10                   
libglut-7.0.1                  
php5-pcre-5.2.4

cclient-2004g,1                
libgmp-4.2.2                   
php5-pdo-5.2.4

clamav-0.91.2                  
libgpg-error-1.5               
php5-pdo_sqlite-5.2.4

compositeproto-0.4             
libiconv-1.9.2_2               
php5-posix-5.2.4_3

curl-7.16.3                    
libksba-1.0.1_1                
php5-session-5.2.4

cvsup-without-gui-16.1h_2      
libltdl-1.5.22_2               
php5-simplexml-5.2.4

damageproto-1.1.0_2            
libmcrypt-2.5.8                
php5-spl-5.2.4

db41-4.1.25_4                  
libmspack-0.0.20040308_3       
php5-sqlite-5.2.4

dirmngr-0.9.7_2                
liboldX-1.0.1                  
php5-tokenizer-5.2.4

dmxproto-2.2.2                 
libtool-1.5.22_4               
php5-wddx-5.2.4

dovecot-1.0.5                  
libungif-4.1.4_5               
php5-xml-5.2.4

encodings-1.0.2,1              
libxkbfile-1.0.4               
php5-xmlreader-5.2.4

evieext-1.0.2                  
libxkbui-1.0.2                 
php5-xmlwriter-5.2.4

expat-2.0.0_1                  
libxml2-2.6.30                 
php5-zlib-5.2.4

fixesproto-4.0                 
m4-1.4.9                       
pixman-0.9.5_2

font-bh-ttf-1.0.0              
makedepend-1.0.1,1             
pkg-config-0.22

font-misc-ethiopic-1.0.0       
mkfontdir-1.0.3                
png-1.2.18

font-misc-meltho-1.0.0_1       
mkfontscale-1.0.3              
portupgrade-2.3.1,2

font-util-1.0.1                
mysql-client-5.0.45            
postfix-2.4.5,1

fontcacheproto-0.1.2           
mysql-server-5.0.45            
printproto-1.0.3

fontconfig-2.4.2_2,1           
netpbm-10.26.44                
pth-2.0.7

fontsproto-2.0.2               
openldap-client-2.3.38         
py25-BitTorrent-5.0.8,1

freetype2-2.2.1_2              
p5-Archive-Tar-1.36            
py25-dnspython-1.5.0

gettext-0.16.1_3               
p5-Authen-SASL-2.10_1          
py25-imaging-1.1.6_1

ghostscript-gpl-nox11-8.60     
p5-Compress-Raw-Zlib-2.006     
py25-numeric-24.2

glib-2.12.13                   
p5-Compress-Zlib-2.006         
py25-opengl-2.0.1.07_4

glitz-0.5.6_1                  
p5-DBD-mysql-4.005             
py25-psyco-1.5.2

glproto-1.4.8                  
p5-DBI-1.59                    
py25-pycrypto-2.0.1_1

gmake-3.81_2                   
p5-Digest-1.15                 
py25-setuptools-0.6c7

gnupg-2.0.4                    
p5-Digest-HMAC-1.01            
py25-tkinter-2.5.1_2

gocr-0.44_1                    
p5-Digest-MD5-2.36             
py25-twistedCore-2.5.0_2

gsfonts-8.11_4                 
p5-Digest-SHA1-2.11            
py25-twistedWeb-0.7.0

gtk-2.10.14_2                  
p5-Encode-Detect-1.00          
py25-wxPython-common-2.6.3.3_1

help2man-1.36.4_1              
p5-ExtUtils-CBuilder-0.19      
py25-wxPython-unicode-2.6.3.3_1

hicolor-icon-theme-0.10_2      
p5-ExtUtils-ParseXS-2.18       
py25-zopeInterface-3.3.0.1

inputproto-1.4.2.1             
p5-GSSAPI-0.24                 
python24-2.4.4_1

intltool-0.36.2                
p5-HTML-Parser-3.56            
python25-2.5.1

jasper-1.900.1_6               
p5-HTML-Tagset-3.10            
randrproto-1.2.1

jbigkit-1.6                    
p5-IO-Compress-Base-2.006      
razor-agents-2.84

jpeg-6b_4                      
p5-IO-Compress-Zlib-2.006      
recordproto-1.13.2

kbproto-1.0.3                  
p5-IO-Socket-INET6-2.51_1      
renderproto-0.9.3

lcms-1.17,1                    
p5-IO-Socket-SSL-1.09          
resourceproto-1.0.2

lha-1.14i_6                    
p5-IO-String-1.08              
rsync-2.6.9_1

libFS-1.0.0                    
p5-IO-Zlib-1.07                
ruby-1.8.6_2,1

libGL-7.0.1                    
p5-MIME-Base64-3.07            
ruby18-bdb-0.6.2

libGLU-7.0.1                   
p5-Mail-SpamAssassin-3.2.3     
scrnsaverproto-1.1.0

libICE-1.0.4,1                 
p5-Mail-Tools-1.74             
shared-mime-info-0.22

libSM-1.0.3,1                  
p5-Math-BigInt-1.86            
tcl-8.4.15_2,1

libX11-1.1.3,1                 
p5-Module-Build-0.28.08        
tiff-3.8.2_1

libXScrnSaver-1.1.2            
p5-Net-1.22,1                  
tk-8.4.15_3,2

libXTrap-1.0.0                 
p5-Net-DNS-0.61                
trapproto-3.4.3

libXau-1.0.3_2                 
p5-Net-IP-1.25                 
unzip-5.52_3

libXaw-1.0.4,1                 
p5-Net-SSLeay-1.30_1           
videoproto-2.2.2

libXcomposite-0.4.0,1          
p5-PathTools-3.25              
wget-1.10.2_1

libXcursor-1.1.9               
p5-Scalar-List-Utils-1.19,1     wxgtk2-2.6.3_4

libXdamage-1.1.1               
p5-Socket6-0.19                
wxgtk2-common-2.6.3_3

libXdmcp-1.0.2                 
p5-Spiffy-0.30                 
wxgtk2-contrib-2.6.3_2

libXevie-1.0.2                 
p5-Storable-2.16               
wxgtk2-contrib-common-2.6.3_2

libXext-1.0.3,1                
p5-String-Approx-3.26          
wxgtk2-unicode-2.6.3_3

libXfixes-4.0.3                
p5-Test-Base-0.54              
wxgtk2-unicode-contrib-2.6.3_2

libXfont-1.3.1,1               
p5-Test-Harness-2.64           
xbitmaps-1.0.1

libXfontcache-1.0.4            
p5-Test-Simple-0.71            
xcmiscproto-1.1.2

libXft-2.1.12                  
p5-URI-1.35                    
xextproto-7.0.2

libXi-1.1.3,1                  
p5-XML-Parser-2.34_2           
xf86bigfontproto-1.1.2

libXinerama-1.0.2,1            
p5-YAML-0.65                   
xf86dgaproto-2.0.3

libXmu-1.0.3,1                 
p5-gettext-1.05_1              
xf86miscproto-0.9.2

libXp-1.0.0,1                  
p5-libwww-5.805                
xf86vidmodeproto-2.2.2

libXpm-3.5.7                   
pango-1.16.5                   
xineramaproto-1.1.2

libXprintAppUtil-1.0.1         
pcre-7.3                       
xorg-fonts-truetype-7.3

libXprintUtil-1.0.1            
pear-1.6.2                     
xorg-libraries-7.3_1

libXrandr-1.2.2                
pecl-filter-0.11.0             
xproto-7.0.10

libXrender-0.9.4               
pecl-hash-1.5                  
xtrans-1.0.4

libXres-1.0.3_2                
pecl-json-1.2.1                
zope29-2.9.7_1

libXt-1.0.5                    
pecl-zip-1.9.0

libXtst-1.0.3                  
perl-5.8.8

[EMAIL PROTECTED] /var/db/pkg]#
_________________________________________________________________
Call friends with PC-to-PC calling -- FREE
http://get.live.com/messenger/overview_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to