Not so long ago I aquired a new laptop. Appart from some issues which were to be expected everything works fine; appart from one thing: When playing videos with mplayer it hangs up my system at random times( Mostly within half an hour of videplayback though ) . The video-playback stops, sound blocks and I can't acces my laptop anymore; not even switch to tty0 to check for debug messages.

My guess is it has something to do with either the audio or the videodriver, respectively snd_hda and the "intel" driver in Xorg. So I did 2 tests, without gaining any additional knowlege however:


I tried unloading the snd_hda module and sound modules and play the video to see if there was a problem with the video-part. I let it ran for a couple of hours and everything seemed to be fine

The second thing I tried was just using mplayer -vo null and playing the video. Same as the above test; it ran fine for a couple of hours straight.

So no I have no Idea anymore what I could do to determine whatever is going wrong. I hope someone else has an idea or might have a pointer to what I could do to gain more information about this. The relevant system data:

[EMAIL PROTECTED] uname -a
FreeBSD Rena.FStaals.net 8.0-CURRENT FreeBSD 8.0-CURRENT #0: Sat Oct 13 12:59:51 CEST 2007 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC i386

[EMAIL PROTECTED] kldstat
Id Refs Address    Size     Name
1   15 0xc0400000 923830   kernel
2    1 0xc0d24000 14e24    snd_hda.ko
3    2 0xc0d39000 52a08    sound.ko
4    1 0xc0d8c000 6b270    acpi.ko
5    1 0xc5672000 11000    ext2fs.ko
6    1 0xc592a000 22000    linux.ko
7    1 0xc5a2d000 6000     i915.ko
8    1 0xc5a33000 f000     drm.ko

[EMAIL PROTECTED] mplayer --version
MPlayer dev-SVN-r24813-4.2.1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz (Family: 6, Model: 15, Stepping: 10)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

[EMAIL PROTECTED] dmesg -a | grep pcm
pcm0: <Intel 82801H High Definition Audio Controller> mem 0xfe9fc000-0xfe9fffff irq 21 at device 27.0 on pci0
pcm0: [ITHREAD]
pcm0: <HDA Codec: Sigmatel (Unknown)>
pcm0: <HDA Driver Revision: 20070710_0047>

[EMAIL PROTECTED] dmesg -a | grep agp agp0: <Intel GM965 SVGA controller> on vgapci0
agp0: detected 7676k stolen memory
agp0: aperture size is 256M


my xorg config; ( which is just basically what X --configure generated ) : http://fstaals.net/junk/xorg.conf

Regards,


--
-Frank Staals


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to