Yesterday I moved from 6.2-RELENG to 7-RELENG and everything worked fine (though I do have a few questions about mergemaster that I'll ask later).

As suggested on this list, I started to rebuild all of my ports.

I started  with

  portupgrade -f '<2007-11-01 12:00'

and all seemed to go well until I realized that I should have added "-- batch" to that. So I interrupted the process and restarted with

  portupgrade -f --batch '<2007-11-01 12:00'

This has been running apparently just fine overnight, but then I noticed that after building each port, they didn't get installed because I was getting an error like

/var/db/pkg/pkgdb.db: unexpected file type or format -- Invalid argument

So I stopped things again and tried to fix pkgdb.db

$ sudo pkgdb -v -F
--->  Checking the package registry database
/var/db/pkg/pkgdb.db: unexpected file type or format -- Invalid argument
$ sudo file /var/db/pkg/pkgdb.db
/var/db/pkg/pkgdb.db: Berkeley DB 1.85 (Hash, version 2, native byte- order)

What should I do now. I suppose that my problem was with interrupting the portupgrade the first time 'round. But is there anything I can do to fix this.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to