hi folks,

i came upon a highly odd problem of aterm dying in ion (stable).
some of the aterm windows are being killed w/o any error messages.

ion has been running since feb 1 4pm (now is feb 4 1a).  when
i tried to run (either via key binding or the query_run ion
function) aterm in an empty frame, it was killed instantaneously.
afterwords i opened netscape, followed by aterm;  no problems this

then i tried to open another (aterm) window from w3m ("open link in
another browser" option key binding) which was also killed after
some modem activity.

"ok" i said.  then i tried to open aterm in another window manager
(fluxbox) in (tight)VNC.  guess what?  yup, aterm window disappeared
as soon it appeared.

heh, get this... after taking away the setuid permission of aterm,
its windows were being kept.  (but then xterm, which had its window
not disappear, is setuid'd too.)  and now restoring the old
permissions of aterm (4755), its windows are being kept again.

i do/did not have this problem w/ long running fvwm (2.5.x), tvtwm,
or blackbox at all.

what the hell is/was going on?

  - parv


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to