Hi,

    So tonight I went to try and upgrade my gkrellm2 port, and found that it failed 
when dealing with a file that was part of my Xft port.  I currently have Xft-2.0_1 
installed.  I went to do a portupgrade of Xft, and this is the error I keep getting:

    gcc -O -pipe  -I. -DHAVE_CONFIG_H -I/usr/X11R6/include 
-I/usr/local/include/freetype2 -I/usr/local/include -I/usr/X11R6/include -fPIC -DPIC 
-c xftdpy.c -o xftdpy.o
    xftdpy.c: In function `XftDefaultSubstitute':
    xftdpy.c:484: `FC_RGBA_UNKNOWN' undeclared (first use in this function)
    xftdpy.c:484: (Each undeclared identifier is reported only once
    xftdpy.c:484: for each function it appears in.)
    gmake: *** [xftdpy.o] Error 1
    *** Error code 2

    Stop in /usr/ports/x11-fonts/Xft.
    ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade93740.0 make
    ** Fix the problem and try again.
    ** The following packages were not installed or upgraded (*:skipped / !:failed)
            ! x11-fonts/Xft (Xft-2.0_1)     (compiler error)


=====

    Anyone have any idea what might be causing this?  I've tried going into 
/usr/ports/x11-fonts/Xft and doing a make deinstall, but my ports no longer point at 
Xft-2.0_1, they point to 2.1 and so it doesn't seem to think Xft is installed (even 
though I see it installed in /var/db/pkg).  Anyways, any help I can get on this would 
be much appreciated.  Thanks in advance.

-- 
     ________________________________________________________________________
                Mike Barrett | "I used to read, now I go to raves."
             [EMAIL PROTECTED] | -- Random MUNI Rider, speaking
              www.daboyz.org |    to my friend Allison.
     ------------------------+-----------------------------------------------

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to