Heiko Wundram (Beenic) writes:
 > Have you tried compiling your program with
 > gcc -fpic -pthread ...
 > ? I don't have any more insight into this problem, at least as I'm not using 
 > dbi and as such am not able to reproduce it, but I'd guess that if your 
 > program doesn't conform to the platform's required thread semantics (which 
 > are turned on by -fpic -pthread) but uses code that does require this, 
 > you're 

Thanks for the hint, but that didn't help. I've changed the appropriate
acinclude.m4, Makefile.am, and configure.in files of both libdbi and
libdbi-drivers to make sure that:

- libdbi.so (the lib that dlopen()s the drivers) is built with -fpic -pthread
- libdbifirebird.so (the firebird driver) is built with -fpic -pthread
- test_dbi (linked against libdbi.so) is built with -fpic -pthread

Still no luck, and the test app crashes at the very same point. Any
other suggestions?


Markus Hoenicka
(Spam-protected email: replace the quadrupeds with "mhoenicka")

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to