QADMOS wrote:
Gelsema, P (Patrick) a écrit :
On Sun, December 23, 2007 23:04, QADMOS wrote:
Jonathan Horne a écrit :
On Sunday 23 December 2007 02:52:43 pm QADMOS wrote:

Hi everyone,

i'm having a hard time with bind9.

I'm trying to set up an authoritative dns server.

Unfortunately when i try to launch it with an 'rndc start' i get this

error message :
 > rndc: connect failed: 127.0.0.1#953: connection refused

I've reviewed my conf files but frankly i couldn't see what was wrong. I've actually rewritten them from scratch several times to really check
that nothing was missing and couldn't see anything was wrong. The
localhost.rev file is configured correctly. I've also tried to
regenerate new rndc.keys and edit named.conf accordingly but to no
avail.

I've also considered a possible file permissions in /etc/namedb and in
/var/run/named issue but that didn't yield much either.

Finally the biggest trouble is that nothing is logged in any log file !
nothing in /var/log/messages nothing in /var/log/all.log nothing
anywhere so i'm really confused here about what direction to
investigate.

Has anyone ever encountered such an issue ?

Thx in advance for any help.

do you get same problem with:

/etc/rc.d/named start

?


Well i've also tried that actually and when i do that :
1/ nothing is logged
2/ nothing is launched either

Do you have the following in rc.conf?

hulk# cat /etc/rc.conf | grep named
named_enable="YES"

To me it seems your problem lies in the fact that named is not starting,
so rndc can not control anything.

Rgds,

Patrick

there's just no error message despite that the named is not running
(checked with ps waux | grep named )

Well Patrick i followed your suggestion and rebooted (it didn't do much after just editing rc.conf) the box and now "/etc/rc.d/named start" works fine annd named is running, 'rndc' still has the same problem though (???)

I'm a bit befuddled though, because i don't understand why it's necessary to use the named_enable directive to have named running ? I understand this is necessary if you want the daemon to run at boot time but why is this necessary if you want to run it manually once the box is on ?

In any case thx a lot for your help :)

the entries in the rc.conf are there for system security. [something] might be installed, but its not supposed to be allowed to run unless the system admin knows about it.

otherwise, there is always 'forcestart' intead of 'start'.

cheers,

--
Jonathan Horne
http://www.dfwlp.org
[EMAIL PROTECTED]

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to