On Jan 1, 2008 10:11 AM, Ashish Shukla आशीष शुक्ल <[EMAIL PROTECTED]> wrote:
> >>>>> "Xn" == Xn Nooby <[EMAIL PROTECTED]> writes:
>     Xn> I am having trouble getting X to use a screen resolution that is less
>     Xn> than the maximum.  When I edit my xorg.conf to add a DefaultDepth and
>     Xn> a Mode of "1024x768", it still comes up at 1280x1024.  I did not
>     Xn> create any modeline entries yet, since I'm not sure how to do that.
>     Xn> My GUI (icewm) works, but browsing the web creates enormous eye-strain
>     Xn> from the high-resolution letters.
>
>     Xn> My hardware is a Dell Inspiron 530 Desktop with an nVidia Card. It
>     Xn> comes with SATA CD's, so I have to install with FreeBSD 7-RC1.
>
>     Xn> I started by running "xorg -configure", and used the xorg.conf that it
>     Xn> generated.  I looked at /var/log/Xorg.0.log, and it had many entries
>     Xn> from probing my hardware.  It appears there is some kind of dynamic
>     Xn> configuration going on, but I know its using the xorg.conf, because it
>     Xn> got an error when I changed the adapter entry from "nv" to "vga".
>
>     Xn> I actually had a similar problem on Ubuntu, and they had some
>     Xn> "xorg-reconfigure" program that would let you use less than maximum
>     Xn> values.  I was wondering if FreeBSD had something similar.
>
>     Xn> The "DefaultDepth 24" and "Modes "1024x786"" entries are from the
>     Xn> online FreeBSD Handbook, I believe I followed the Handbook
>     Xn> instructions properly.
>
>     Xn> Am I missing something obvious?  From using Linux, I was expecting the
>     Xn> "Modes" values to work.
>
> "TargetRefresh", and "PreferredMode" options, available in recent Xorg
> releases (probably since 7.2), you'll require. I'm using
> "TargetRefresh" (75 Hz) on my Intel 945G graphics to set my monitor to
> display 1440x900 rather than 1280x1024. And this same configuration is
> working fine for both FreeBSD 7.0-BETA4 (amd64), and Ubuntu 7.10 (amd64).
>
> HTH
> --
> Ashish Shukla आशीष शुक्ल                      http://wahjava.wordpress.com/
> ·-- ·- ···· ·--- ·- ···- ·- ·--·-· --· -- ·- ·· ·-·· ·-·-·- -·-· --- --
>

When I create a "PreferredMode" value, the X-Server hangs when I run
startx.  I cannot end X with ctrl-alt-backspace, but I can reboot with
ctrl-alt-del.  I am using xorg 7.3 (installed via 'pkg_add -r xorg'),
and this was apparently a known bug.  I'm not sure if it is supposed
to be fixed in now, the bug was from September:

http://bugs.freedesktop.org/show_bug.cgi?id=12476

I also tried "TargetRefresh" with values of 60 and 75, but it did not
seem to do anything. When you use TargetRefresh, is that with the
Horizontal and Vertical refresh values - or does it replace them?
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to