Erik Trulsson wrote:
On Sun, Jan 06, 2008 at 02:10:59PM +0100, Walter Jansen wrote:
Hi

Upon reading chapters of the Handbook about the Ports collection and CVSup,
I wanted to CVSup the ports collection for the RELEASE  6.2. Stupidly using
the wrong tag (tag=.), I erroneously but successfully installed the CURRENT
version. I could have used SYSINSTALL for the RELEASE 6.2 ports, but for the
sake of learning and training myself I did not.

Problem:
  - I ran CVSup again with the correct tag but though everything in the
process looked normal, the map usr/ports remains empty and nor with whereis
nor with pkg_xxx any information about ports can be found. Questions: - What did I do wrong in the process?.


You used the wrong tag.

If you want the exact version of the ports tree that shipped with 6.2 the
correct tag to use is "RELEASE_6_2_0".  "RELENG_6_2_0_RELEASE" is the tag
used for the base system corresponding to 6.2-RELEASE.


  - Is cvsup for installation of RELEASE 6.2 ports collection a bad idea
anyway (technically) ?

If you actually want the ports tree as it was when 6.2-RELEASE was made,
then it is not a bad idea.  Most of the time one would like a more updated
version of the ports tree though.



Proces:

- I use the recently installed cvsup-without-gui, installed from ports
- I deleted all entries and maps in/under /usr/ports (as recommended in the
Handbook)
- I modified the ports-supfile in usr/share/examples/cvsup and copied it to
portswj-supfile  in the same map (not good practice I know now....)

The settings in the -supfile where:

*default host=cvsup15.FreeBSD.org
  *default base=/var/db

  *default prefix=/usr

  *default release=cvs tag=RELENG_6_2_0_RELEASE   (the handbook suggests
that this is a valid tag for ports)

I doubt the handbook suggests that.  If it does it is wrong.

  *default delete use-rel-suffix   (I could not find a meaning for this in
the books, anyone can tell me please?)

Read the cvsup(1) manpage.

  *default compress

  ports-all

- I ran:  cvsup -L 2 /usr/share/examples/cvsup/portswj-supfile

The conversation looked OK, no error messages but also no scrolling list of
files

There is a logfile in  /var/db/sup ports-all, something like
<nnnnn>.cvs:RELENG_6_2_0_RELEASE. It shows a list of all the elements of the
ports collection that looks normal and every record shows also
RELENG_6_2_0_RELEASE.




One idiotic question on the top of his troubles.

According to the disclaimer posted on the ports web-site. The ports tree supports only Stable and Current version of the OS.

Since Release is sort of more stable than the Stable I wonder if there is a frozen ports three with frozen packages for 6.2 release?

Personally, I was always following stable branch which is moving target as you know. One needs to portsnap fetch and update ports three
before every build up and also portupgrade has to be done fairly regularly.
Personally, I could not care less for the newest versions of the programs as long as the old one are stable so for me staying with release would be perfectly OK.



_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to