On Jan 8, 2008 9:48 AM, Andy Elvey <[EMAIL PROTECTED]> wrote:
> Hi all -
>  I've recently installed FreeBSD 6.2-release - very impressed!
> Just a small problem. I'm unable to mount my USB key as a user.  ( I can
> mount it as root,  using the
> command  "mount -t msdos /dev/da0s1 /mnt "  )
> This is what I get when I try to mount it as a user -
> $ mount -t msdos /dev/da0s1 /home/andy
> mount_msdosfs: /dev/da0s1: Permission denied
> $ mount -t msdos /dev/da0s1 /mnt
> mount_msdosfs: /dev/da0s1: Operation not permitted
> I followed the instructions in the FAQ ( section 9.23 ) to the letter (
> the only change being that that doesn't mention
> USB devices, so I've substituted the USB device name  da0 for the device
> names there.  )

hmmm, seems to be broken for me....

- man devfs.rules

- create /etc/devfs.rules: ( substitute wheel for the group you want )

add path 'da*s*' mode 0660 group wheel

- append to /etc/rc.conf:


- make sure the dir you are mounting on is owned by the user who
issues the mount command.

- make sure vfs.usermount=1

- reboot after changing devfs.rules & rc.conf

worked for me, let us know if it worked for you.


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to