On Thursday 10 January 2008 06:52:38 am Unga wrote:
> Hi all
>
> I want to run ddd debugger under root.
>
> I ran following before become root:
> xhost localhost
>
> Under root:
> echo $DISPLAY
>
> :0.0
>
> When I run ddd:
> Xlib: connection to ":0.0" refused by server
> Xlib: No protocol specified
>
> Error: Can't open display: :0.0
>
> What else I should do in FreeBSD? I'm running
> 7.0-PRERELEASE on i386 with KDE 3.5.8.
>
> Appreciate very much a reply.
>
> Best Regards
> Unga

im not sure if its the best or correct way, but i was able to run an app (not 
ddd, i dont have that on my system) as root by doing this:

(as my user)
xhost +

(then su - up to root)
xcalc -display :0

nothing else to it.  also, you might take a look at the man for xhost to see 
how to narrow down the access, because the '+' only gives you a nice 
little "you are now wide open for connections" message.

cheers,
-- 
Jonathan Horne
http://dfwlpiki.dfwlp.org
freebsd08 [EMAIL PROTECTED] dfwlp.com
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to