----- Original Message -----
From: "Dan Nelson" <[EMAIL PROTECTED]>
Sent: Thursday, February 06, 2003 10:28 PM
Subject: Re: Does spamd use Razor?

> In the last episode (Feb 06), Mark said:
> >
> > I recently installed SpamAssassin 2.44, with Razor 2.22. And although
> > spamd says that Razor2 is available, its -D debug parameter does not
> > allow for a high enough debug-level to actually see whether spamd
> > calls Razor; the log says,
> >
> > spamd[4013]: debug: running full-text regexp tests; score so far=9.1
> > spamd[4013]: debug: Razor2 is available
> > spamd[4013]: debug: entering helper-app run mode
> > spamd[4013]: debug: leaving helper-app run mode
> >
> > When I run via spamassassin, everything seems ok, and Razor fills its
> > logs (in /var/log/razor-agent.log); but run via spamd, only the above
> > is logged (in the spamd log; nothing in /var/log/razor-agent.log).
> >
> > I built this on FreeBSD 4.7R, against /usr/local. Has anyone else
> > done this with success on their FreeBSD system? And what am I
> > missing?
> Try piping the test-message through spamc:
> spamc < /usr/local/share/doc/p5-Mail-SpamAssassin/sample-spam.txt |
> grep -i razor

Thanks for the quick reply. :)

> Spamd might not be running as root so it may not have write access to
> /var/log/razor-agent.log.

Indeed, I have spamd running as the special, unprivileged user "spamd". But
you were right: spamd did not have access to /var/log/razor-agent.log. I
could have sworn that I had done a "chown spamd:spamd
/var/log/razor-agent.log" on it. But when I checked it again, it was owned
by "root:wheel". I must be going senile. :)

Well, thanks anyway; you solved it. :)

- Mark

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to