[EMAIL PROTECTED] wrote:
On 18/01/2008, Ben Williams <[EMAIL PROTECTED]> wrote:
Hi all,

I've got a problem with fsck_msdosfs. My FAT32 drive came up with errors
after a power-failure-induced reboot, and recommended that I run
fsck_msdosfs manually. However, fsck_msdosfs fails:

# fsck_msdosfs /dev/ad3s1
** /dev/ad3s1
** Phase 1 - Read and Compare FATs
No space for FAT (Cannot allocate memory)#

I've tried googling for it and I can't find anything other than a bug
being mentioned/filed for netbsd which is obviously related, but no fix
was forthcoming.

Does anyone have any ideas how I can proceed?

Are you still in single user mode at this point?

Well, I was.

I have made a tiny bit of progress - I edited /etc/fstab and turned the fsck at boot time off for that drive, so I can boot normally now, just without that drive mounted. However, I still get the same error message from fsck_msdosfs.

I am able to run top at the same time, as as far as I can tell, it doesn't actually run out of memory - Mem has ~564k free, and Swap has 158mb free at its lowest when fsck_msdosfs is running. It's an old machine, with 192mb ram, and 359mb swap.

 - Ben
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to