I have some strange behavior with some files and some directories
being doubled on samba. When checking on freebsd file system all is
OK. Mounting partitions on windows clients or connecting with
smbclient would show some doubled files or directories. I mean the
same file appear twice. When deleting one from windows both disappear
but copying back the file from backup, again I have 2 files with the
same name.

smb: \> ls DATA\RON\E*
 EURO.XG0                            A     4096  Wed Jan 23 14:58:44 2008
 EURO.XG0                            A     4096  Wed Jan 23 14:58:44 2008

First I've upgraded samba to the latest port version (samba-3.0.28,1) - no joy.

I've made a jail (maybe the ports are messed?) only with samba. Same result.

I've source upgraded to 6.3-RELEASE. Nice but didn't solve the problem.

The system was stable and I cannot relate any software maintenance
with the beginning of this behavior.

Any pointers would be appreciated.

Is this the case for all your shared folders? I found this thread with no answers (http://fixunix.com/samba/328376-samba-duplicate-filename-samba-3-0-28-a.html) where the problem hapens for a specific share and that too with a specific file.

Have you tried this with a default config file? Or say one with minimal changes?

Since when did this problem begin happening? Any extra info you can find in the logs?

I've used Samba 3.0.25-28 on FreeBSD 6.2 and 6.3 but haven't encountered such a problem. Maybe you could add some stuff ''case sensitive = no'' and ''preserve case = yes'' to see if the file name case is making any difference. Just a shot in the dark, actually.


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to