First off, you should probably update your ports tree. Firefox is now
at 2.0.0.11,1, and xorg-libraries is at 7.3_1.


I started with updating the ports tree.


Then try the upgrade again. If it still fails, show us the errors from
the xorg-libraries build.

[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 685 packages found (-0 +1) . done] ---> Upgrading 'xorg-libraries-7.2_1' to 'xorg-libraries-7.3_1' (x11/xorg-libraries)
--->  Building '/usr/ports/x11/xorg-libraries'
===>  Cleaning for xorg-libraries-7.3_1
/usr/X11R6 exists, but it is not a symlink. Installation cannot proceed.
This looks like an incompletely removed old version of X. In the current version, /usr/X11R6 must be a symlink if it exists at all.Please read /usr/ports/UPDATING (entry of 20070519) for the procedure to upgrade X.org related ports.*** Error code 1

Stop in /usr/ports/x11/xorg-libraries.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.15405.6 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=xorg-libraries-7.2_1 UPGRADE_PORT_VER=7.2_1 make
** Fix the problem and try again.

------------------------------------

OK, so it looks like I have to update Xorg ports first. Reading UPDATING it seems quite a lot of work. Can you tell it will work out ok?

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to