Chris Maness wrote:
Predrag Punosevac wrote:
Chris Maness wrote:
I have a "headless" box where I upgraded from 7.2 to 7.3 per the security issue, now I am unable to start vnc. I get:

$ less\:1.log

Xvnc Free Edition 4.1.2 - built Dec  1 2007 13:55:16
Copyright (C) 2002-2005 RealVNC Ltd.
See for information on VNC.
Underlying X server release 40300000, The XFree86 Project, Inc

Sat Jan 26 21:59:51 2008
vncext:      VNC extension running!
vncext:      Listening for VNC connections on port 5901
vncext:      Listening for HTTP connections on port 5801
vncext:      created VNC server for screen 0
error opening security policy file /usr/local/lib/X11/xserver/SecurityPolicy Could not init font path element /usr/local/lib/X11/fonts/Speedo/, removing from list! Could not init font path element /usr/local/lib/X11/fonts/CID/, removing from list! Could not init font path element /usr/local/lib/X11/fonts/75dpi/, removing from list! Could not init font path element /usr/local/lib/X11/fonts/100dpi/, removing from list!

Fatal server error:
could not open default font 'fixed'
xsetroot:  unable to open display ''

These fonts are installed.  Very wierd.

If I run the command:

pkg_info | grep xorg

// I get //

linux-xorg-libs-6.8.2_5 Xorg libraries, linux binaries
xorg-7.3_1          X.Org complete distribution metaport
xorg-apps-7.3 apps meta-port
xorg-docs-1.4,1 documentation files
xorg-drivers-7.3_1 drivers meta-port
xorg-fonts-100dpi-7.3 X.Org 100dpi bitmap fonts
xorg-fonts-7.3 fonts meta-port
xorg-fonts-75dpi-7.3 X.Org 75dpi bitmap fonts
xorg-fonts-cyrillic-7.3 X.Org Cyrillic bitmap fonts
xorg-fonts-miscbitmaps-7.3 X.Org miscellaneous bitmap fonts
xorg-fonts-truetype-7.3 X.Org TrueType fonts
xorg-fonts-type1-7.3 X.Org Type1 fonts
xorg-libraries-7.3_1 libraries meta-port
xorg-protos-7.3 protos meta-port
xorg-server-1.4_4,1 X.Org X server and related programs

Any ideas folks?
Try to erase .vnc and start server again.

I tried that one to no avail. I just re-built/installed the xfont server, and all its dependencies, but this still did not fix the problem. portupgrade -fr xfs-1.0.5,1

I feel like ripping out all the ports and starting from scratch, but I can't do that as this is a production server :o(

If you are using TightVNC server you may try to install X11VNC and forget about TightVNC server and vise verse. They should not conflict each other. You can also try to pkg_delete and to clean configuration files and reinstall the VNC server you are using.

I am little bit surprised that you are running X let alone VNC server on the production machine. Are you aware of the fact that you can display programs that run on your server on the another machine in X even though X itself doesn't run on your server. That can be done via ssh tunel.

Read the page 91 from the book Secure Architectures with OpenBSD.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to