Rek Jed wrote:

I also tried building it like that:

# cd /usr/src/sys/boot
# make LOADER_TFTP_SUPPORT=YES  LOADER_NFS_SUPPORT=NO

This builds fine.  I copied it to my jumpstart server and it booted from
tftp after approx 2 min. pause and the "NFS MOUNT RPC error: 60".  Can
anyone tell me whats the difference between -DLOADER_TFTP_SUPPORT=YES
and LOADER_TFTP_SUPPORT=YES?

OK, two things remain: Are you sure that it doesn't correctly fetch the kernel with tftp and then the kernel tries to mount a root device with nfs?

If the kernel is compiled with the slightest mention of nfs as root device it will use nfs, no matter that you have specified otherwise in loader.conf. The generic kernel has NFS_ROOT and NFS_CLIENT, since your root device is not NFS then you can leave out both. I recall having problems leaving in NFS_CLIENT although NFS_ROOT was not included.

Second, the loader is ignorant of which version of FreeBSD you use, it will just load whichever kernel you throw at it. I have a loader I used
for 6.1, http://www.locolomo.org/pub/pxeboot/jumpstart.tgz

Hope this helps. If you find any errors or things that have changed since I worked with this, let me know and I will update the howto.

Cheers, Erik
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to