On 09/02/2008, Mitja <[EMAIL PROTECTED]> wrote:
> Hi!
>
> After update to ICU 3.8.1 there were some problem but after rebuilt of glib
> everything works okay again. Today I tried to update GIMP and there are again
> problem with ICU, need to be version 3.6:
>
> "/libexec/ld-elf.so.1: Shared object "libicui18n.so.36" not found, required
> by "gdk-pixbuf-csource"
> gmake[2]: *** [gimp-tool-cursors.h] Error 1
> gmake[2]: Leaving directory
> `/usr/ports/graphics/gimp-app/work/gimp-2.4.4/cursors'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory `/usr/ports/graphics/gimp-app/work/gimp-2.4.4'
> gmake: *** [all] Error 2
> *** Error code 2
>
> Stop in /usr/ports/graphics/gimp-app.
> *** Error code 1
>
> Stop in /usr/ports/graphics/gimp-app.
> ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.32005.0
> env UPGRADE_TOOL=portupgrade UPGRADE_PORT=gimp-app-2.4.3,1
> UPGRADE_PORT_VER=2.4.3,1 make
> ** Fix the problem and try again.
> --->  Skipping 'graphics/py-gimp' (py25-gimp-app-2.4.3) because a requisite
> package 'gimp-app-2.4.3,1' (graphics/gimp-app) failed (specify -k to force)
> --->  Skipping 'graphics/gimp' (gimp-2.4.3,2) because a requisite
> package 'py25-gimp-app-2.4.3' (graphics/py-gimp) failed (specify -k to force)
> ** Listing the failed packages (-:ignored / *:skipped / !:failed)
>         - ftp/curl (marked as IGNORE)
>         ! graphics/gimp-app (gimp-app-2.4.3,1)  (unknown build error)
>         * graphics/py-gimp (py25-gimp-app-2.4.3)
>         * graphics/gimp (gimp-2.4.3,2) "

My solution was to issue:
portupgrade -ufr icu

While likely not the most elegant, it completed
without error and everything /seems/ to work
fine.

-- 
--
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to