On Sunday 17 February 2008 01:06:28 pm Dimitri Yioulos wrote:
> I'm not sure whether to have posted this here or on a VMware list;
> apologies if I'm in the wrong place.
>
> The other day, I did a fresh install of v. 7RC2 from the minimal CD on
> a CentOS 5.1 box running VMware server 1.0.4.  I had previously
> successfully installed v. 6.2, and upgraded to 6.3 on the same box. 
> All has gone well, except for the installation of VMware Tools. 
> Getting the Tools tarball and extracting the requisite files was
> trivial. However, when I try to run Vmware-Config-Tools.pl, I get a
> message saying that the program must be run on a virtual machine. 
> Well, it is.  Is there a needed FBSD package I'm missing (the Tools
> install program doesn't complain about it).  A known issue, or bug, 
> maybe?  Or is VMware support not yet enabled?  Help would be greatly
> appreciated.

I just went through almost the same thing, installing FreeBSD 7 under 
VMware Workstation on Windows. The config-tools script has a hard-coded 
version check which looks for libc.so.6 under /lib only. Rather than mess 
with the script, I just hard-linked the library 
from /usr/local/lib/compat (where it was installed by the compat6x port). 
Seemed to work fine after that. You'll need to be careful not to erase it 
if you ever run "make delete-old-libs", though.

JN

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to