Am 21.02.2008, 23:55 Uhr, schrieb paulfromottawa <[EMAIL PROTECTED]>:

My printer isn't working with freebsd I have a hp laserjet1000

"/usr/local/libexec/cups/filter/foomatic-rip failed"

So I have tried building the kernel without ulpt, and uploader the firmware
but then cups would have local printers selection greyed out.

using boot loader.conf
to load ulpt corected that but still no test prints worked.

Loading ulpt via the loader has the same effect as compiling it into the kernel.
Don't do that. You need your printer as a ugen device.

You do have hplip installed? It is in the ports and comes with a ``hp-setup'' program.
Use filter /usr/local/share/ppd/HP/HP-LaserJet_1010-hpijs.ppd.gz

Maybe this helps:
Look for the section "FREEBSD NOTES". It is about uploading firmware to a Laserjet 1018.
You probably need to be root to upload.

If your printer is detected by cups, you will still need to replace /usr/bin/lpr with /usr/local/bin/lpr for your applications to print.

Check out ``hp-toolbox'', too.


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to