Denny White wrote:

On Thu, Feb 28, 2008 at 02:46:41AM -0700, Predrag Punosevac sez:
Denny White wrote:


For the last couple of days I've tried everything I can think of to
make XForwarding work with ssh. As per the FAQ, I have set it like so:

In sshd_config

X11Forwarding yes

In ssh_config

ForwardAgent yes
ForwardX11 yes

I can use it passably well in one direction from a box across the
room to the one I do most of my work on. But, when I try it from
this box to the one across the room, I get the xauth error message
along with all typed characters doubled on the screen. I went ahead
anyway and typed 'display somefile.jpg' just to see what I'd get &
got this:

Xlib: connection to "localhost:10.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
display: unable to open X server `localhost:10.0'.

I've read the man page on xauth(1) and experimented with its
commands. I've even wiped out the .Xauthority file on both boxes
and restarted X, to no avail. Possibly I should mention too, that
I boot on both boxes to a xdm login. I don't know if that would
have any bearing on the problem or not. Thanks for any help I
can get on this.
What happens when you try to do the following?

Try to do remote login with as follows

I get this:

Warning: No xauth data; using fake authentication data for X11

And, everything I type at the prompt is doubled.
you should be now in the shell on the remote host

try to start x client like xdvi or xfig or something like emacs by typing xdvi

If xdvi pops up that means that the client is running on the remote host but it is displayer on the local X server

Okay, if after getting in I try to open something like xzgv, I get:

Xlib: connection to "localhost:10.0" refused by server
Ok you do have a permission problem

Read carefully man pages for sshd_config file . You need to uncomment few lines for X tunneling. You can also look at the "Secure Architectures with OpenBSD" section about OpenSSH.

I do not think that the problem is with X server though.

Xlib: Invalid MIT-MAGIC-COOKIE-1 key

Gtk-WARNING **: cannot open display: localhost:10.0
Like I said earlier, I read the man page too on xauth & tried

xauth extract - $DISPLAY | rsh otherhost xauth merge -

but it doesn't appear to help. I still get the error messages
and double typed characters.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to