Drew Sanford a écrit :
Peter wrote:
Drew Sanford wrote:
| Command line programs for php seem to segfault on a 7.0RC1 box (yes, I
| know, I should update to RC2) - for example:
|
| [EMAIL PROTECTED](~/bin)$ php -v
| PHP 5.2.5 with Suhosin-Patch 0.9.6.2 (cli) (built: Feb 9 2008 13:03:20)
| Copyright (c) 1997-2007 The PHP Group
| Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
| zsh: segmentation fault (core dumped)  php -v
|
| Any pointers? Just update and see if that fixes it? Thanks in advance.
|
|
| uname output:
| FreeBSD colossus.cotharyus.net 7.0-RC1 FreeBSD 7.0-RC1 #0: Sat Feb  9
| 11:43:37 CST 2008


  Getting same thing, fresh install of 7.0 [cvsupped to rc2?], latest or
not latest portsnap, I found it was the 'mhash.so' extension that was
causing php to segfault - did portsnap update, and rebuilt all php
stuff, still does same thing - have not tried it for last several weeks,
so could be fixed by now...I did cvsup to latest sources...
my emails were subjected "apache coredump with 'mhash' php extension
enabled" - with mhash disabled, php works fine now.  Will try and
buildworld/reinstall php with the latest 7 sometime soon.

]Peter[


Good find Peter, I've got exactly the same system config at this point, and disabling mhash fixed it as well.
Same problem with php5-mhash. I build it from the port, using FreeBSD7.0-RELEASE. I use PHP as apache module.

Any ideas ?

Thanks.


-Nicolas

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to