Kris Kennaway wrote:
Kevin Kinsey wrote:


<snip>

I get the following from uname -a:

FreeBSD archangel.daleco.biz 6.2-RELEASE FreeBSD 6.2-RELEASE #6:
Sat Jun  2 09:22:50 CDT 2007  [EMAIL PROTECTED]:
/usr/obj/backup/src/sys/GENERIC  i386

However, I rebuilt world, more or less without issues,
twice in February with "RELENG_6" in the supfile.  This
didn't change uname's output, and that worried me a bit.

So, to make matters bette^H^H^H^Hadder, I csup'ped
to RELENG_7_0 the day after it was released, read
/usr/src/UPDATING, and the webpage detailing the
upgrade, and did another buildworld/kernel cycle.
Now I have no idea if I'm on 6 or 7 (seems like
7, but many ports issues, and I've rebuilt them
all), and it's just becoming a major PITA.


You didnt succeed in installing the new kernel. 'make installkernel' is the step in which this occurs.

Kris

Thank you and Phillip for answering my post.  However,
I've done this 3 times now, and I don't skip that step.
There have been no errors in the process, either.

AAMOF, in response to Phillip's mail, I just did it
again, as you can see (z* is to omit snipping):

ll /boot/kernel/z*
-r-xr-xr-x  1 root  wheel   712006 Mar  3 15:16 /boot/kernel/zfs.ko*
-r-xr-xr-x  1 root  wheel  3471592 Mar  3 15:16 /boot/kernel/zfs.ko.symbols*
-r-xr-xr-x  1 root  wheel    38175 Mar  3 15:16 /boot/kernel/zlib.ko*
-r-xr-xr-x  1 root  wheel    58834 Mar  3 15:16 /boot/kernel/zlib.ko.symbols*

I've rebooted the system, and I'm still being told I'm running
6.2 by uname.  In addition, pkg_add thinks I should be looking
for 6-latest packages instead of 7, and the list of annoyances
continues.  And, "hmm", symbols?  I'm guessing that knob is ON
in FBSD7?  Once again, proof that something's wrong, as I didn't
build debugging kernels in FBSD6 ... so I'm thinking this is
a 7 kernel?  It just doesn't make sense to me.

It *is* a Monday, after all.
If installkernel didn't succeed, shouldn't there be any
other evidence?  Could skipping a mergemaster at some point
have this effect? (I don't *always* do that, unless I'm making a pretty big move, and the first build cycle was
production code IIRC)

What about issues with "newvers.sh" (or whatever it is?)
Any other think-outside-the-box stuff?  What could cause
an installkernel operation to fail but appear to succeed?

KDK
--
I just rewrote my .sig.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to