Dimitri Yioulos wrote:
On Tuesday 04 March 2008 4:20 pm, Kris Kennaway wrote:
Dimitri Yioulos wrote:
On Tuesday 04 March 2008 3:32 pm, Robert Davison wrote:
I've tried to update 6.3 to 7 using the sh freebsd-update.sh -f
freebsd-update.conf -r 7.0-RELEASE upgrade process. I thought all had
gone well untill I started getting lib-XXX.so4 missing file here and
libphp.so missing there. I'm guessing that the update process has
deleatd some shared libararies which are still required.

I have the files in question, but instead of XXX.so.4, the file is
called XXX.so.5

I followed the instructions to the 'T' but nothing seems to work i.e
MailScanner, apache etc.

I've tried portupgrade -af to see if I can link the ports to the new lib
files, but alas nothing.

Anyone got any ideas??
Perhaps someone has a better suggestion for you, but I had a similar
issue with regard to installing VMware Tools.  In my case, I symlinked
libc.so.5 linked to libc.so.6, and the VMware Tools installation
Ah yes, I forgot about bogus advice option 2 :-)


As I said, someone might have a better suggestion, as I'm a relative noob. My point was to try symlinking your needed library file to that which you find on your system. I'd think it'd be worth a try. But, hey, if it's bogus advice (option 2 :-) ), then best of luck.

The reason it's bogus is because we change library versions for good reason: they are incompatible.

Sometimes they are incompatible in obvious ways, sometimes in subtle ways. If you need libc.so.5 to run a FreeBSD 5.x binary, install the compat5x port. That is not the solution for the OP though, because at this point he has binaries with an inconsistent set of libraries that needs to be fixed by moving them all to 7.0.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to