Tim Daneliuk wrote:
I just bought a new MSI P4M900M2 mobo.  It works just fine with both
Windoze and SUSE Linux.  When I tried booting 6.2 on it, it refused to
set the drive (ad0 - I tried several different drives) into the
higher speed UDMA modes.  So, I downloaded 6.3, and it *seemed* to
be fine.  The drives come up as UDMA 100 or UDMA 133.

But ... under long disk operations - say untaring a 2G tarball
stored on a USB drive - I start to see this:

ad0: WARNING WRITE_DMA UDMA ICRC ERROR


I have resolved this and thought I'd share with the class in case
anyone else runs into the problem.

It occurred to me that this chipset has been around long enough that
it was very likely not a driver problem. I went back and replaced the
IDE cable with another one known to be good and, voila', problem
solved.

What's weird about this is that the "bad" cable is a more-or-less new
low profile round IDE cable I got from Tiger Direct a while back. It
is the 20" variety which may be contributing noise to the problem.
Weirder still is that neither Linux nor Windows seemed to have
problems with it, though I did not test as thoroughly with those OSs.
I'd guess that the FBSD driver is perhaps trying to squeeze the last
bit of optimization out of the controller and thus drives the IDE bus
to its limits, hence the problem shows up there.  Either that,
or I just didn't pound on the machine hard enough with Linux
especially to see the problem.

I should have guessed "cable problem" right away, but given the
relative newness of the cable, that seemed unlikely.

In a related note: I also discovered that the FreeBSD install CD Fixit
environment does flakey things when you try to untar a large file from
a USB drive plugged in through an external hub. Plugging the drive
directly into one of the mobo ports made that problem go away.




--
----------------------------------------------------------------------------
Tim Daneliuk     [EMAIL PROTECTED]
PGP Key:         http://www.tundraware.com/PGP/

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to