A few months ago, I posted asking about how good support the Realtek 8111B
PCI Express LAN chipset is.
The conclusion was that its behavior was rather flaky on FreeBSD 7.0

Anyway, I got the motherboard with the chip integrated because the MOBO
otherwise did what I needed.
After installation of FreeBSD/i386 the chip was detected and the re driver
attached but DHCP configuration wouldn't work. After searching on the
internet, I found some patches at



and applied them.

After rebuilding the kernel, everything worked.
Shortly after I decided I was going to run the FreeBSD/amd64 version
I had not kept the patches that worked on i386, so I downloaded from the
same URL again.
However, this time, applying the patch resulted in no change: DHCP
configuration still wouldn't work.

Now, I'm not sure what variable is responsible for this, the change to amd64
or whether there was another version of the patch. Interestingly, in the
thread where I found those links, people were running amd64 and had their
problems resolved. I noticed that the version of if_re.c file was 107 the
second time whereas the post said it was 101.
I'm guessing the file was updated at the URL and this resulted in a
The problem is, I'm not in a position to say exactly which version worked.

Is there anyone on the list close to this work and would have an idea of
what happened?
I am currently using a PCI lan card that works with the rl driver but it
would be nice to have the integrated chip work too.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to