Dear All,

I was playing with various scanners and all-in-one devices on FreeBSD (probably 6-7 different scanners and all-in-one devices) and I noticed that the range of scanners supported on FreeBSD is far smaller than that of sane-backends. This is due to the fact that there is no standard device class for USB scanners. Therefore for instance uscanner driver will only recognise devices whose USB IDs are explicitly listed in the table in the driver itself. Parallel port scanners and all-in-one devices are even in worse shape due to the limitation of lpt driver but they can be considered semi-obsolete so I didn't even bother to play with them.

I was wondering if anybody has tried manually to add the device and the vendor ID to uscanner.c and recompile the kernel. Will that work. In particular last night I played little bit with Epscon CX3810 all-in-one which I got for $5. The device is recognized as /dev/ulpt0 and is usable as a printer with the Gutenprint driver. If I remove ulpt and umass driver from the kernel the device is seen as ulpt but sane-find-scanner list it as Unknown device. I tried to edit /usr/local/etc/sane.d/epson.conf and add the vendor name and the product ID but the scanner is not responsive. The CX3810 is fully supported by Epson and Epson2 backend and works out of box on Ubuntu.

Did anybody play with these things at all or people are using just a few usable devices ( I have couple of working scanners on FreeBSD for instance)?

Another question. Is it possible to unload driver from the kernel without recompiling it like on OpenBSD
with config utility.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to