Mark Moellering wrote:
On Friday 28 March 2008 06:23:49 am Kris Kennaway wrote:
Mark Moellering wrote:
I have been trying to install an i386 jail on an amd64 install.  I added
Target=i386 to the command line in the make buildworld and installworld
commands.  I keep getting the following (or similar) error
'Target' does nothing, there is no such variable.  If you meant
'TARGET', that is a real variable but not the one you want.  You need to
add 'TARGET_ARCH=i386' to your build/installworld to successfully
cross-compile.

Kris

Kris, Thanks for the reply.
I aplogize, I should have been more explicit.

I tried TARGET=i386 ; TARGET_ARCH=i386; and both together, all gave the same error.

(/libexec/ld-elf.so.1: Shared object "libedit.so.6" not found, required by "sh")

Have you or has anyone else on the list successfuly done this?

Yes, frequently. Does the library exist in the chroot and is it an i386 library (use file(1))?

Kris
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to