On Sat, 2008-03-22 at 19:08 +0100, Kris Kennaway wrote: 
> Frank Solensky wrote:
> > I'm attempting to add FreeBSD 7.0 onto a free disk partition on my Sony
> > Vaio (VGN-FZ340E; Intel Core 2 Duo processor; 3 GB memory) and am
> > running into a "Fatal Trap 19" while running the installation disks.
> > Here's the last screenful of messages:
> > 
      fwohci0: <1394 Open Host Controller Interface> mem 
0xfc102000-0xfc1027ff,0xfc104000-0xfc107fff irq 17 at device 3.1 on pci9
      fwochi0: [FILTER]
      fwochi0: OHCI version 1.10 (ROM=1)
      fwochi0: No. of Isochronous channels is 4.
      fwochi0: EUI64 08:00:46:03:02:91:55
> >   NMI ISA b0, EISA FF
> >   RAM parity error, likely hardware failure
> > 
> >   fatal trap 19: non-maskable interrupt trap while in kernel mode
> >   instruction pointer     = 0x8:0xFFFFFFFF802da7cf
> >   stack pointer           = 0x10:0xFFFFFFFF80a738f0
> >   frame pointer           = 0x10:0
> >   code segment            = base 0x0, limit 0xfffff, type 0x1b
> >                           = DPL 0, pres 1, def32 0, gran 1
> >   processor eflags        = interrupt enabled, IOPL = 0
> >   current process         = 0 (swapper)
> >   trap number             = 19
> >   panic: non-maskable interrupt trap
> >   cpuid = 0
> >   uptime = 1s
> > 
> > The above is from the attempt with 7.0 amd64; I've been stopped with
> > similar errors on disks with 7.0 amd64 bootonly, 7.0 i386, 6.3 amd64 and
> > 6.1 amd64.  I believe the "RAM parity error" is a red herring: I haven't
> > had any problems running Linux or Vista on this machine and running
> > Memtest86+ overnight didn't turn up any problems.
> > 
> > http://updraft3.jp.freebsd.org/cgi/query-pr.cgi?pr=i386/107564 appears
> > to be similar but unresolved.
> > 
> > Trying with ACPI disabled stops at:
> >   md0: Preloaded image </boot/mfsroot> 4194304 bytes at 0xFFFFFFFF80bc6c08
> >   Trying to mount root from ufs:/dev/md0
> > 
> > Any suggestions?  Thanks in advance..
> 
> The other OSes may be recovering (with performance penalty) from your 
> RAM errors due to additional code not present in FreeBSD.  In my 
> experience this error is not a red herring, it indicates a real problem 
> with your memory.

After retesting with the current version of memtest86+ and discovering
no problems, then still running into the same error after taking each
memory chip out of the portable, I brought the machine back to the
store's service department.  They didn't find anything either.

I'm suspecting that there may be some problem in the firewire driver
since that's where the final messages are coming from.

So what I'd like to do at this point is find some way to disable loading
the firewire driver to see if I can get the install process going any
further than that.  I've tried going into the command line interface and
entering "set hw.firewire.enable=0" but that doesn't seem to have any
effect.  And I don't believe I can build a custom kernel without
firewire if I can't get the initial install going.

So where to go from here?


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to