Hi
I've just changed ISP and I am having some issues with PPP and large packets.


I've got a Draytek Vigor 100 ethernet modem which proxies PPPoA <-> PPPoE so I can initiate the PPPoE connection to my ISP from my FreeBSD 7.0-STABLE box. This worked perfectly with my previous ISP but now any packets larger than 1500 bytes and thus requiring fragmentation which arrive in do not make it to the tun0 ppp interface.

For example here I initiate a large ping from outside my network to the machine on which my ppp client is running -
# ping -s 1500 -c 1 88.129.153.191

This is what arrives on the physical vr1 interface on which pppoe is running

002774 00:50:7f:8c:f2:08 > 00:00:24:c9:57:39, ethertype PPPoE S (0x8864), length 1018: PPPoE [len 1502 > 998!] [ses 0x3ec] unknown (0x2021), length 998: unknown PPP protocol (0x2021)
        0x0000:  4500 eb13 4357 2000 3301 0334 5775 d0c5
        0x0010:  5895 9ac6 0800 6190 ffe8 0000 47fc a40e
        0x0020:  0000 efd9 0809 0a0b 0c0d 0e0f 1011 1213
        0x0030:  1415 1617 1819 1a1b 1c1d 1e1f 2021 2223
        0x0040:  2425 2627 2829 2a2b 2c2d
000040 00:50:7f:8c:f2:08 > 00:00:24:c9:57:39, ethertype PPPoE S (0x8864), length 538: [ver 4] [type 5]PPPoE [len 1502 > 518!] [ses 0x20c] unknown (0x009e), length 518: unknown PPP protocol (0x009e)
        0x0000:  4500 d3ea 4357 2000 3301 0334 c8c9 cacb
        0x0010:  cccd cecf d0d1 d2d3 d4d5 d6d7 d8d9 dadb
        0x0020:  dcdd dedf e0e1 e2e3 e4e5 e6e7 e8e9 eaeb
        0x0030:  eced eeef f0f1 f2f3 f4f5 f6f7 f8f9 fafb
        0x0040:  fcfd feff 0001 0203 0405
000011 00:50:7f:8c:f2:08 > 00:00:24:c9:57:39, ethertype PPPoE S (0x8864), length 70: PPPoE [ses 0x6] IP (0x0021), length 50: (tos 0x0, ttl 51, id 17239, offset 1480, flags [none], proto ICMP (1), length 48) 87.119.223.147 > 88.129.153.191: icmp

This is all that arrives on the tun0 ppp interface

15. 242441 AF IPv4 (2), length 52: (tos 0x0, ttl 51, id 18322, offset 1480, flags [none], proto ICMP (1), length 48) 87.119.223.147 > 88.129.153.191: icmp

If anyone can decipher this and give me an idea of what's going wrong I'd be most grateful.
Thanks
Gianni
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to