On Apr 12, 2008, at 4:47 PM, Roland Smith wrote:

On Sat, Apr 12, 2008 at 01:32:22AM -0500, Joshua Isom wrote:

I haven't. DVD's work fine here with mplayer on amd64.

Same here, and vcd's playing out of the cd drive.

When trying to play a vcd in mplayer I just get a CDRIOCSETBLOCKSIZE
error.

I get no errors at all actually.

There are tools in ports to rip a VCD. See multimedia/vcdimager.

For wayward devices to can try using cdcontrol(1) or atacontrol(8).

Roland


After some further testing, a vcd in the dvd drive will have the same problem during booting the kernel(before init). After killing the system and rebooting without the disc, trying to play the disc causes messages like this repeatedly. I tried running "cdcontrol -f /dev/acd1 eject" and it hung. I tried "atacontrol reinit ata3" and "atacontrol detach ata3" and those hung as well. It's an sata dvd-rw drive over atapi. Here's the error being reported by the kernel.

acd1: TIMEOUT - READ_BIG retrying (1 retry left)
acd1: TIMEOUT - READ_BIG retrying (0 retries left)
acd1: FAILURE - READ_BIG timed out

Mplayer just triggers the problem. I imagine if I ran amd I'd have the same type of problem, or any program that tried to read from acd1. Other than locking up tty's and not being able to shut down, the system's still usable, aside from the disc inserted during boot of course.

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to