Kris Kennaway <[EMAIL PROTECTED]> writes:

>> Sorry Kris, I was in part plain wrong in my first reply to this one.
>>
>> Linking /compat/linux/usr/X11R6 to /compat/linux/usr/local fixed my
>> initial problem
>>
>>
>>>>>>>>>>> | /usr/compat/linux/opt/openoffice.org2.4/program/soffice.bin:
>>>>>>>>>>> | error while loading shared libraries:
>>>>>>>>>>> | /usr/local/lib/libXext.so.6: ELF file OS ABI invalid
>>
>> What I still don't get is why ldconfig doesn't find the the X11R6
>> directory, when /compat/linux/etc/ld.so.conf point at it
>>
>>
>> include ld.so.conf.d/*.conf
>> /lib
>> /usr/lib
>> /usr/local/lib
>>
>> it seems to be ignoring the first line.
>>
>> Either there is a real problem here or the real problem is my ignorance,
>> and I'm not sure which it is!
>
> You re-ran the ldconfig command that rescans the specified directory
> to rebuild its cache, right? :)

Well - the problem was my own blindness.  There was a LD_LIBRARY variable
in .bashrc which seems to have messed up the linux path stuff. Get rid of
that, run the ldconfig just to be sure, and all works as it should.  I
had *completely* forgotten it was there - have just moved to FreeBSD from
Linux, after three years of dithering!, and had not removed that line
when I brought my .bashrc with me.

Sorry for the noise, and *many* thanks for all the help - as always I've
learned some useful things.


atb



Glyn
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to