don't use gmirror and atacontrol at the same time.  Use one or the other.


> -----Original Message-----
> [mailto:[EMAIL PROTECTED] On Behalf Of 
> Nejc Škoberne
> Sent: Thursday, May 22, 2008 1:51 AM
> To: User Questions
> Subject: RAID 0+1
> Hello,
> I have FreeBSD 7.0 and 4 250GB SATA disks and I would like to 
> make one big 500GB
> 0+1 RAID array. My hardware is HP ProLiant ML110G5.
> First I tried creating ATA RAID arrays with BIOS tools, but 
> FreeBSD wouldn't recognize the arrays.
> Than I decided to create the RAID-0 arrays with atacontrol. I 
> succeeded, ending up with ar0 and ar1 each 500GB big. My plan 
> was to install the FreeBSD as usual on ar0 and then add both 
> into a gmirror array. However, I BootMgr seem not to be able 
> to boot from RAID-0 array created with atacontrol? Is this 
> correct? I guess this is because BootMgr knows nothing about 
> striping and cannot read the kernel.
> Finally I tried to create two slices on each drive. The plan 
> was to join the first slice of all 4 drives into a gmirror 
> array and mount it as / partition (I guess BootMgr would boot 
> normally from such an array). Then I would merge the second 
> slice of all 4 drives into a 0+1 array (first gstriping and 
> then gmirroring them). I somehow succeeded this, but I also 
> get a WARNING when booting the system:
> ad0: 238475MB <WDC WD2500YS-70SHB1 20.06C06> at ata0-master SATA150
> ad1: 238475MB <Seagate ST3250620NS 3BJP> at ata0-slave SATA150
> ad2: 238475MB <GB0250C8045 HPG1> at ata1-master SATA150
> GEOM_STRIPE: Device gs0 created (id=2160028923).
> GEOM_STRIPE: Disk ad0s2 attached to gs0.
> ad3: 238475MB <GB0250C8045 HPG1> at ata1-slave SATA150
> GEOM_STRIPE: Disk ad1s2 attached to gs0.
> GEOM_STRIPE: Device gs0 activated.
> GEOM_STRIPE: Device gs1 created (id=3269017453).
> GEOM_STRIPE: Disk ad2s2 attached to gs1.
> GEOM_MIRROR: Device mirror/gm0 launched (4/4).
> GEOM_STRIPE: Disk ad3s2 attached to gs1.
> GEOM_STRIPE: Device gs1 activated.
> WARNING: Expected rawoffset 0, found 63
> GEOM_MIRROR: Device mirror/gm1 launched (1/2).
> GEOM_MIRROR: Device gm1: rebuilding provider stripe/gs1.
> Is this critical? It looks like the system is fine, though.
> Is there any "more proper" way to build such a system with RAID 0+1?
> Thanks,
> Nejc
> _______________________________________________
> mailing list 
> To unsubscribe, send any mail to 

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to