you use freebsd/i386 not /amd64 isn't it?

On Tue, 3 Jun 2008, The Ghost wrote:


Maybe I just don't understand something, but anyway, it looks really odd.

I have a machine with 2 Gb RAM with a clean newly-installed FREEBSD-7.0-RELEASE. I make 
two 300-MB mdconfig disks and populate them, and when the first one was already full and 
the second one is only half-full, I get a kernel panic "not enough memory". I 
wonder where did 1,5 Gb go?? Well, I tried to reboot and allocate them with -o reserve to 
prevent the kernel panic, but the second one said that enough memory can't be allocated 
(though top still showed 1,5 Gb left). Well, I rebooted and tried to allocate one 1-Gb 
disk, but it also failed. Then I gave up on this and came to my other work, but when I 
loaded some small kernel module, I got a kernel panic!! What, didn't the disk allocation 
have to kinda free up the used memory when it fails?! And then the last thing. I reboot 
and copy a 220-m file from a samba-mounted directory to my hard drive (UFS2 with 
soft-updates). I was very surprised to see that one gigabyte of my memory suddenly became 
used up. I wonder if the soft-up!
es really don't care about how much memory they use...

A friend of mine told me that such a panic is really a thing to write a 
bugreport on it, but I know about this behaviour for few years already and so I 
guess I just don't know something about the memory allocation system, and, 
kinda, it really works just like that. Should I read something to understand 
why it's just like that or really write a report on some of these things?..

                                          The Ghost <[EMAIL PROTECTED]>

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to