kevin kempter wrote:
Hi All;

 This seems to be more of a lib not found than a vm issue:


I've done this:

1) installed freeBSD 7 in vmware fusion (v 1.1.3)

2) selected to install vmware tools from the menu

3) logged into the console as root

4) mounted the vmware virtual cd

5) copied the vmware tools tar.gz file to /tmp

6) expanded the vmware tools tar.gz file in /tmp

7) cd to the new vmware-toold-distrib dir and ran ./vmware-install.pl

 Then I get this:



Before running VMware Tools for the first time you need to configure it by invoking the following command: "/usr/local/bin/vmware-config-tools.pl". Do you want this program to invoke the command for you now? [yes]



/usr/libexec/ld-elf.so.1: Shared object "lib.so.6" not found, required by "vmware-checkvm"

/usr/libexec/ld-elf.so.1: Shared object "lib.so.6" not found, required by "vmware-checkvm"

/usr/libexec/ld-elf.so.1: Shared object "lib.so.6" not found, required by "vmware-checkvm"

This configuration program is to be executed in a virtual machine.



Execution aborted.





I also tried starting KDE and in a Konsole terminal window (as root) running /usr/local/bin/vmware-config-tools.pl and I get the same results





Anyone have any thoughts?



Thanks in advance...




Funny thing, I was doing the same steps today in vmware workstation ;) Had the same problems, and the following is the solution:

Install the compat6x port. Seems the vmware tools are for the 6.X version of FreeBSD, not native 7.

As root:

cd /usr/ports/misc/compat6x
make install clean

Also, create the following symbolic link (This is where vmware searches for the library):

ln -s /usr/local/lib/compat/libc.so.6    /lib

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to