On Jun 4, 2008, at 11:04 AM, Manolis Kiagias wrote:

kevin kempter wrote:
Hi All;

This seems to be more of a lib not found than a vm issue:


I've done this:

1) installed freeBSD 7 in vmware fusion (v 1.1.3)

2) selected to install vmware tools from the menu

3) logged into the console as root

4) mounted the vmware virtual cd

5) copied the vmware tools tar.gz file to /tmp

6) expanded the vmware tools tar.gz file in /tmp

7) cd to the new vmware-toold-distrib dir and ran ./vmware-install.pl

Then I get this:



Before running VMware Tools for the first time you need to configure it by invoking the following command: "/usr/local/bin/ vmware-config-tools.pl". Do you want this program to invoke the command for you now? [yes]



/usr/libexec/ld-elf.so.1: Shared object "lib.so.6" not found, required by "vmware-checkvm"

/usr/libexec/ld-elf.so.1: Shared object "lib.so.6" not found, required by "vmware-checkvm"

/usr/libexec/ld-elf.so.1: Shared object "lib.so.6" not found, required by "vmware-checkvm"

This configuration program is to be executed in a virtual machine.



Execution aborted.





I also tried starting KDE and in a Konsole terminal window (as root) running /usr/local/bin/vmware-config-tools.pl and I get the same results





Anyone have any thoughts?



Thanks in advance...




Funny thing, I was doing the same steps today in vmware workstation ;) Had the same problems, and the following is the solution:

Install the compat6x port. Seems the vmware tools are for the 6.X version of FreeBSD, not native 7.

As root:

cd /usr/ports/misc/compat6x
make install clean

Also, create the following symbolic link (This is where vmware searches for the library):

ln -s /usr/local/lib/compat/libc.so.6    /lib


Thanks for the advice, this allowed me to install the vmware tools.

I had the vm in such a state that I thought it best to start from scratch, so I did the following:

1) installed freeBSD7 into a new VM
2) Followed the steps above to install the compat6x lib and created the link to /lib
3) installed the vmware-tools
4) ran the vmware-config (/usr/local/bin/vmware-config-tools.pl)
5) installed kde via pkg_add -r kde
6) created a .xinitrc for root like this:
    echo "exec startkde" > ~/.xinitrc
7) tried to start kde by running startx and I get an error that the driver "vmware" in the xorg config file does not exist.

I've attached the log from my attempt to start kde (Xorg.0.log) - from /var/log
and my xorg.conf file (from /etc/X11)

Thanks in advance for any help...

/Kevin








_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to