Can we no longer use "make buildworld" to upgrade from source builds? Everytime 
I've tried, I get build errors. I've gotten the impression from a few things 
I've read that freebsd-update is suppose to be used. I don't want a binary 
install/upgrade though. I've just sync from CVS with this in the config:

*default host=cvsup15.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=RELENG_7
*default delete use-rel-suffix
*default compress
src-all


Pretty much the same config I've always used, except the RELENG_7.

I continually get errors when "make buildworld". I went back to the 6.3 source, 
and successfully "make buildworld". 

My current attempt at buildword with the 7.0 died like this:
*********************************************************************
===> usr.bin/awk (obj,build-tools)
yacc -d -o awkgram.c /usr/src/usr.bin/awk/../../contrib/one-true-awk/awkgram.y
yacc: 43 shift/reduce conflicts
yacc: 85 reduce/reduce conflicts
ln -sf awkgram.h ytab.h
cc -O -pipe -DHAS_ISBLANK -I. -I/usr/src/usr.bin/awk/../../contrib/one-true-awk 
-DFOPEN_MAX=64  -I/usr/obj/usr/src/tmp/legacy/usr/include  
-L/usr/obj/usr/src/tmp/legacy/usr/lib 
/usr/src/usr.bin/awk/../../contrib/one-true-awk/maketab.c  -o maketab
===> lib/libmagic (obj,build-tools)
cc -DHAVE_CONFIG_H -DCOMPILE_ONLY  -I/usr/src/lib/libmagic 
-I/usr/src/lib/libmagic/../../contrib/file -o mkmagic 
/usr/src/lib/libmagic/../../contrib/file/apprentice.c 
/usr/src/lib/libmagic/../../contrib/file/funcs.c 
/usr/src/lib/libmagic/../../contrib/file/magic.c 
/usr/src/lib/libmagic/../../contrib/file/print.c
===> usr.sbin/sysinstall (obj,build-tools)
cc -o rtermcap /usr/src/usr.sbin/sysinstall/rtermcap.c -ltermcap
===> gnu/usr.bin/cc/cc_tools (obj,depend,all)
make: don't know how to make 
/usr/src/gnu/usr.bin/cc/cc_tools/../../../../contrib/gcc/ansidecl.h. Stop
*** Error code 2

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*********************************************************************


The previous attempt died due to a missing tconfig.h.  Can anyone shed some 
light on this please? I can't remember ever having trouble with a buildworld 
before!!

TIA,
Casey
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to