Lowell Gilbert <[EMAIL PROTECTED]> wrote: "Dr. Jennifer Nussbaum"  writes:

> Im trying to upgrade some ports, and have a problem with libcdio. At least i
> think i do. 
> When i try to upgrade, say, Nautilus (or a buncha other things), it dies in 
> the
> end with a "libcdio-0.78.2_2 is already installed. You may wish to make 
> deinstall"
> etc. message.
> But i did go to /usr/ports/sysytils/libcdio and make deinstall and make 
> reinstall,
> and this was successful. I sync'd the ports collection again, but no luck. 
> Nothing
> in UPDATING about this.

Sounds like the dependencies are confused.  pkgdb(1) may help with
that.  If not, the brute force approach would be to remove the
affected ports all the way back to (and including) libcdio, and build
them over.
I havent been able to figure out how to fix things with pkgdb. And i have 
tried, over and over, to remove the affected ports and build them from scratch 
but it hasnt been working.

So i went to libcdio and did a make deinstall, deleted the work files, and did 
a make install clean, and it installed fine. Then i tried to build gvfs, also 
by doing a make install clean, and it died in the same way--telling me to make 
deinstall and make reinstall of libcdio.

Ive tried this several times with no luck. If theres an even more brute force 
way id like to know what it is so i can do that. This is preventing a lot of 
other upgrades to GNOME, which i need.



freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to