> The /home filesystem was full (121G partition on a 3ware escalade raid)
> So i deleted 7G, but df did not show any difference. The fs is mounted w/
> soft-updates. I issued a sync command, but still no change. The files were no
> longer shown in ls, but space was not freed. So i decided to reboot, to make
> sure that the deleted files are not still opened by some process.
> The shutdown went normal, but at the end it said:
> sysncing disks..
> 3321 3321 3321 3316 .....
> giving up on 1 buffers.
> When rebooting, all fs were unclean and i had to wait the usual 20 minutes for
> fsck to complete.

I've seen the same 'df' situation when softupdates are enabled, but I've never tried 
to resolve the problem with a reboot.  I just
ignore the 'df' output, and proceed normally.  After some time passes, 'df' returns to 
reporting the expected values.  I've always
thought this was normal with softupdates.  However, I've not had your problem with the 
fsck, but then again...  I've not rebooted
soon after deleting 7GB of data from a file system.

What are you running?  4.6.2, 4.7, -current?


--daxbert


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to